0

I have Ubuntu 14.04 and I've just updated my TeXstudio to version 2.12.10.

While the previous version (around 2.8) used to check spelling and did the hyphenation correctly, now it does not work at all.

What I've tried:

  • download the OpenOffice '.oxt' dictionary and install (via the button) it in Settings of TeXStudio (once directly from 'Downloads' registry, once moved it - with sudo permission - to /usr/share/ directory and)
  • adding /usr/share/hunspell, where I found the correct cs_cZ.aff and cs_cZ.dic files, to paths in "Preferences -> Language Checking" and "Preferences -> Spelling Dictionary Directories" enter image description here
  • I haven't found out, what .dat file I could put into the "Slovníková databáze" (= "Dictionary database") line
  • always restarted TeXstudio after each change.

  • interesting behaviour: a word is underlined iff it contains czech diacritic, when clicking on it with right-button, either the word is (despite being very common word) not in the dictionary or it appears wrongly encoded

  • so I tried changing the encoding of .aff and .dic file from the original ISO 8859-2 into UTF-8, but no effect.

Any idea what to try next?

  • TXS seems to have recognized the cs_CZ dictionary that you have in the hunspell folder (you have it selected in "Vychozi jazyk"). Where did you download the .oxt from? – Troy Jul 23 '18 at 15:53
  • @Troy I downloaded it from extensions.openoffice.org/en/project/dict-cs. – pepa.dvorak Jul 23 '18 at 18:34
  • Works fine here. When you say it does not work, what exactly does that mean? Czech words are marked by TeXstudio as wrong spelling? Or...? What language dictionary is TeXstudio using to check in that case? (Right click on a "wrongly spelt" Czech word in your document: what spelling suggestions pop up?) – Troy Jul 23 '18 at 18:47
  • Exactly - most of czech words (even common, non-math) are marked red. The suggestion is either non-existing ("Add to dictionary" even for common words) or incorrectly coded (aha!?). However, now, when I look at marked words, those are underlined iff they contain czech diacritic! So maybe some coding error in dictionaries? – pepa.dvorak Jul 23 '18 at 18:57
  • 1
    @Troy Solved, finally! – pepa.dvorak Jul 24 '18 at 7:39
1

Download Czech.dic and Czech.aff from https://github.com/titoBouzout/Dictionaries, rename to cs_CZ.dic and cs_CZ.aff, link texstudio to them and you're done - the issue is really in encoding; seems it cannot be solved by mere re-encoding original files into utf-8.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.