1

I tried to use the IPE to make graphs. I'm having problems with pdftex. Every time I try to write a mathematical command, the software returns me this error,that I reported on the programmer's site: otfried/ipe-issues

I tried setting the PATHS in the .bash_profile, but I did not have any kind of result. Ipe keeps returning the error.

This is my .bash_profile

#local bin path:

#LaTeX path:
export PATH=/usr/local/texlive/2018/bin/x86_64-darwin:$PATH

export PATH=$PATH:/Library/TeX/Distributions/.Defaults/TexLive-2018/Contents/Programs/texbin

#export PATH=/usr/local/texlive/2018/bin/x86_64-darwin/pdftex"$"PATH

Have a solution?

Text labels"

! LaTeX Error: Environment equation* undefined.

See the LaTeX manual or LaTeX Companion for explanation.
Type  H <return>  for immediate help.
 ...                                              

l.52 \begin{equation*}

Your command was ignored.
Type  I <command> <return>  to replace it with another command,
or  <return>  to continue without it.

! Missing $ inserted.
<inserted text> 
                $
l.53 \alpha

I've inserted a begin-math/end-math symbol since I think
you left one out. Proceed, with fingers crossed.

LaTeX Font Info:    External font `cmex10' loaded for size
(Font)              <7> on input line 53.
LaTeX Font Info:    External font `cmex10' loaded for size
(Font)              <5> on input line 53.
! TeX capacity exceeded, sorry [input stack size=5000].
\end #1->\csname end#1
                      \endcsname \@checkend {#1}\expandafter \endgroup \if@e...
l.55 \end
         {minipage}\iperesetcolor}
If you really absolutely need more capacity,
you can ask a wizard to enlarge me.

Paragraphs here

! LaTeX Error: Environment equation* undefined.

See the LaTeX manual or LaTeX Companion for explanation.
Type  H <return>  for immediate help.
 ...                                              

l.52 \begin{equation*}

Your command was ignored.
Type  I <command> <return>  to replace it with another command,
or  <return>  to continue without it.

! Missing $ inserted.
<inserted text> 
                $
l.53 \alpha

I've inserted a begin-math/end-math symbol since I think
you left one out. Proceed, with fingers crossed.

LaTeX Font Info:    External font `cmex10' loaded for size
(Font)              <7> on input line 53.
LaTeX Font Info:    External font `cmex10' loaded for size
(Font)              <5> on input line 53.
! TeX capacity exceeded, sorry [input stack size=5000].
\end #1->\csname end#1
                      \endcsname \@checkend {#1}\expandafter \endgroup \if@e...
l.55 \end
         {minipage}\iperesetcolor}
If you really absolutely need more capacity,
you can ask a wizard to enlarge me.


Here is how much of TeX's memory you used:
 1165 strings out of 492649
 13948 string characters out of 6129622
 76496 words of memory out of 5000000
 5120 multiletter control sequences out of 15000+600000
 3640 words of font info for 14 fonts, out of 8000000 for 9000
 1141 hyphenation exceptions out of 8191
 5000i,5n,4999p,165b,181s stack positions out of 5000i,500n,10000p,200000b,80000s
!  ==> Fatal error occurred, no output PDF file produced!
  • Is "HightSierra" the same as "High Sierra"? If so, please fix the typo in the title of your posting. Please also post a minimal example that generates the issue you're trying to fix. In particular, do please show line 51 of your code, since it looks like one or two $ symbols are missing. – Mico Jul 24 '18 at 18:10
  • @Mico In this particular case the user doesn't have the code. Ipe has a quite long preamble defining colors, so anything the user does starts at line 50 :/ – Phelype Oleinik Jul 24 '18 at 18:35
2

This is not related to the OS you are using nor to the paths, because pdfTeX is running file according to the linked log.

The problem is you are mixing text and math mode.

To insert inline math you can:

First option: use the "Mathematical symbols" button and write the equation without the surrounding $...$:

enter image description here

Second option: use the "Text labels" button and write the equation with the surrounding $...$:

enter image description here

To insert display math, then you have to use the "Paragraphs" button and write as you would in LaTeX:

enter image description here

  • I keep having problems. I inserted some images to the post – Antonio Jul 24 '18 at 19:50
  • @Antonio You posted the header of the logs. These are not of much use because they are more or less standard. Please post the end of the logs, where the errors appear. – Phelype Oleinik Jul 24 '18 at 19:53
  • I entered, I hope correctly – Antonio Jul 24 '18 at 20:00
  • @Antonio Oops, this one was my fault, sorry. equation* is not defined in LaTeX, but in amsmath, thus the error you showed in the log. Use equation (without the *) or one of the other methods I showed. – Phelype Oleinik Jul 24 '18 at 20:08
  • 1
    @Antonio There are a couple of problems is in the equation that says \frac{1}{\rho_{_{0}}}u'_{ij}. First one, it has two \begin{equation} instead of a \begin and an \end. Second, you inserted this equation using the "Text labels" button, but you cannot use displayed equations (such as, \begin{equation}...\end{equation}) with this button. Instead, use the "Paragraphs" button (third alternative from my answer). If you fix these two problems it should work. – Phelype Oleinik Jul 24 '18 at 23:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.