0

I am not experienced at working with biber, but recently my bibliography has shown an odd problem. With multiple authors (>5) the bibliography does not print the 4th- 5th authors name whatsoever. here is my mwe

     \documentclass[11pt,a4paper]{article}
     \usepackage[utf8]{inputenc}
     \usepackage[english]{babel}
     \usepackage{amsmath}
     \usepackage{amsfonts}
     \usepackage{amssymb}
     \usepackage{graphicx}
     \usepackage[left=2cm,right=2cm,top=2cm,bottom=2cm]{geometry}
     \usepackage[
       backend=biber,
       style=apa,
       isbn=false,
       doi=false,
       url=false,
       natbib=true,
       dashed=true, 
       sortlocale=auto, 
       uniquelist=false,
       maxcitenames=1, 
       mincitenames=1, 
       maxbibnames=99,
       minbibnames=4, 
       giveninits=true, 
       uniquename=false, 
       hyperref=auto, 
       ]{biblatex}

 \addbibresource{citations.bib}


 \begin{document}
 \citep{Nejstgaard2008, araujo2015}

 \printbibliography
 \end{document}

the bib entries look like this:

         @article{Nejstgaard2008,
         title={Quantitative PCR to estimate copepod feeding},
         author={Nejstgaard, Jens C and Frischer, Marc E and Simonelli,    Paolo and Troedsson, Christofer and Brakel, Markus and Adiyaman, Filiz and Sazhin, Andrey F and Artigas, L Felipe},
    journal={Marine Biology},
    volume={153},
    pages={565--577},
    year={2008},
    publisher={Springer}
     }
    @article{araujo2015,
    title={Feeding niche preference of the mudsnail \textit{{P}eringia ulvae}},
    author={Araújo, Cristiano VM and Moreira-Santos, Matilde and Patrício, Joana and Martins, Irene and Moreno-Garrido, Ignacio and Blasco, Julián and Marques, JC and Ribeiro, Rui},
    journal={Marine and Freshwater Research},
    volume={66},
    pages={573--581},
    year={2015},
    publisher={CSIRO}
    }

once the document is compiled the missing author is replaced with "..." instead of the name. I imagine its a simple setting issue, but any suggestions are greatly appreciated :-)

  • You have minbibnames=4, so you should get the fourth one showing, but not the fifth, I think. Change it if you want more shown in the bibliography. – cfr Jul 25 '18 at 12:59
  • 1
    The style=apa is causing this behaviour. – NBur Jul 25 '18 at 13:04
  • 2
    APA does not obey the maxcitenames=1, mincitenames=1, maxbibnames=99, minbibnames=4, settings fully. The APA guidelines are very specific and a bit more complex than just (min|max)(bib|cite)names, so you do not have full control over the names as in the standard styles. The behaviour should be compliant to APA style and that is what you get if you use biblatex-apa. You can set the option apamaxprtauth=999 to show all authors, but that won't be APA compliant. – moewe Jul 25 '18 at 13:14
  • See also tex.stackexchange.com/q/230452/35864 – moewe Jul 25 '18 at 13:15
  • Thanks everyone, I have changed the bibliographstyle and now it works beautifully :-) – Maria Jul 25 '18 at 13:49
1

Thanks to everyone who responded, I have now changed the style of my bibliography from 'apa' to 'authoryear-comp' and now it works beautifully :-).

  • 1
    Note that authoryear-comp is significantly different from apa, so I'm wondering why you went with apa in the first place - it really only makes sense if you want to follow APA instructions by the letter. – moewe Jul 25 '18 at 13:55
  • the main reason I chose apa was that it did not put the title in "" marks, if you are aware of a different style I could use, that would be fantastic. – Maria Jul 25 '18 at 14:07
  • Well, my go-to styles are the standard styles, so authoryear-comp seems like a good idea. The great thing about biblatex is that you can change small things like the title formatting quite easily, see tex.stackexchange.com/q/12806/35864 – moewe Jul 25 '18 at 14:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.