I just installed Miktex (2.9, 64-bit, the default download) on this machine and tried using it with Texmaker but the compilation seems to crash. I tried running pdflatex from a terminal and got the following:

ERROR: Windows API error 87: The parameter is incorrect.

ERROR: Info:
path="C:\Users\user\AppData\Local\MiKTeX\2.9\miktex/data/le\df2
c24cb21984fa85003c1ecc818ff83.fndb"
ERROR: Source: Libraries\MiKTeX\Core\MemoryMappedFile\win\winMemoryMappedFile.cpp
ERROR: Line: 83

Does anybody know how to fix this? I tried reinstalling but it didn't help.

  • Normally this means that something is open, e.g. the console, and blocks the fndb. – Ulrike Fischer Jul 26 at 12:59
  • @UlrikeFischer Oh, so I cannot use pdflatex while the console is open? Let me try.... – Anonymous20DB28 Jul 26 at 13:03
  • @UlrikeFischer You were right! Would you mind adding this as an answer so I can accept it? – Anonymous20DB28 Jul 26 at 13:06
up vote 2 down vote accepted

Normally this error means that some miktex tool is open (today mostly the console) and blocks the fndb.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.