1

I updated Mactex 2018 today and got a polyglossia error from then on. (Package polyglossia Error: I cannot switch `:' on or off--not a shorthand.)

There where no changes in the document... Is there a problem with polyglossia?

Update: Thanks for the help. I restored the old bibleref version and everything works well.

%!TEX TS-program = Xelatex
%!TEX encoding = UTF-8 Unicode
\documentclass[12pt,headsepline,pagesize=auto,ngerman,greek,hebrew,english,russian,latin,bibliography=totocnumbered,oneside]{scrreprt}
\usepackage{bibleref-german}
\biblerefstyle{TRE} 
\biblerefformat{kurz} 
\usepackage[comma=chvsep]{bibleref-parse} 
\newcommand{\bible}[1]{\pibibleverse{#1}}
\usepackage{fontspec}
\usepackage{xunicode}
\sloppy 
\usepackage{polyglossia}
\setdefaultlanguage{german}
\setmainlanguage[spelling=new,babelshorthands=true]{ngerman}
\usepackage{bidi}
\TeXXeTstate=1
\setmainfont[%
Mapping=tex-text,%
Script=Latin%
]{Minion Pro}
\begin{document}
Bla Bla. \bible{Mk10,51} zum Beispiel\ldots\ Package polyglossia Error: I cannot switch `:' on or off--not a shorthand.
\end{document}
\endinput
  • 1
    There was a change in biblref a few days ago: tug.org/pipermail/tex-live-commits/2018-July/007018.html That probably caused it. I have not updated my distribution and can't reproduce the error before the update. I'll make the update and report back. – moewe Jul 31 '18 at 7:22
  • 1
    BTW: You don't want \setmainlanguage and \setdefaultlanguage, you can only have one. Instead of \setmainlanguage[spelling=new,babelshorthands=true]{ngerman} you want \setmainlanguage[spelling=new,babelshorthands=true]{german}. polyglossia does not use babel names for language variants. xunicode is normally not needed any more and \sloppy as a global setting in the preamble seems like a bad idea. Your global options ngerman,greek,hebrew,english,russian,latin also don't do a lot at the moment - they are not picked up by polyglossia. – moewe Jul 31 '18 at 7:23
  • 1
    Yup, after an update to the newest bibleref I can reproduce the error. – moewe Jul 31 '18 at 7:30
  • Here is a shorter MWE that shows that the error is unrelated to polyglossia specifically. It is a general babel/polyglossia problem and happens for all languages for which : is not active: \documentclass[british]{article} \usepackage{babel} \usepackage{bibleref} \begin{document} \bibleverse{Gen} \end{document} – moewe Jul 31 '18 at 7:53
  • 2
    @moewe: Imho the problem is that bibleverse uses \shorthandoff: without actually checking if : is a shorthand or not. – Ulrike Fischer Jul 31 '18 at 8:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.