2

I have following problem using the glossarie-extra usepackage. Everytime I want to compile my document I get the following error message for bib2gls:

Missing aux file. Use --help for help.
(Use --help or -h for help.)
C:\texlive\2018\bin\win32\runscript.tlu:803: command failed with exit code 1:
java.exe -jar c:\texlive\2018\texmf-dist\scripts\bib2gls\bib2gls.jar

I have the same problem using the example files from dickimaw-books

A minimal example of the tex-file:

\documentclass[
    11pt,
    paper=a4,
    DIV=calc,
    oneside
]{scrreprt}

\usepackage{fontspec}
\usepackage[utf8]{inputenc} 
\usepackage[english]{babel}
\usepackage{blindtext}      

\usepackage[
record,
nomain,%no main glossary, only acronyms and symbols
translate=babel,%tanslates the headings into bable language
%index, %create index
abbreviations,% create list of abbreviations
%symbols,% create list of symbols
%postdot % append a full stop after the descriptions
%toc %adds glossaries to the table of contents
]{glossaries-extra}
\GlsXtrLoadResources[
src={abbreviations},% data in abbreviations.bib
]


\begin{document}
Test \gls{mcbj}
\end{document}

In the abbreviations.bib, there is the following code:

@abbreviation{mcbj,
short ="MCBJ",
long = {mechanically-controlled break-junction},
}

Instead of printing the correct abbreviation, I alway get ?? and there is for sure no entry in the glossary. (Not included in the minimal example).

I think the main problem is, that the correct aux file can't be found and therefore bib2gls does not work correctly. Anybody an idea how to fix the problem?

Thanks and greetings!

2
  • Welcome! Is the .aux produced? Do you get errors when you run the first compilation (before you run bib2gls)?
    – cfr
    Aug 1 '18 at 1:36
  • The main.aux is produced. There are also some references to bib2gls. I run lualatex -> bib2gls -> lualatex in that order. I tried pdflatex, too, but I won't work neither.
    – Patrick
    Aug 1 '18 at 6:34
1

Ok, I found the problem: wenn running the bib2gls command, there was a space character between the % and the .aux. So the complete command to convert the .tex is now:

lualatex.exe -synctex=1 -interaction=nonstopmode %.tex
bib2gls %.aux
lualatex.exe -synctex=1 -interaction=nonstopmode %.tex

and it works ;)

Thanks and greetings!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.