2

When using scrbook and the appendix package I get dots after chapter and section numbers. If the minimal example below is combiled with pdflatex once the first page looks like desired and the .aux file is created.

enter image description here

If it is combiled a second time with .aux file present it looks like this:

enter image description here

with additional dots. The issue does not appear if I comment out the marked line below.

\documentclass{scrbook} 
\usepackage{appendix}
\begin{document}
\chapter{Chapter}
\section{Section}
\begin{appendices} 
\chapter{Appendix Chapter} % comment out this line to compile without dot after chapter and section numbers
\section{Appendix Section}
\end{appendices}
\end{document}
1

It is based on a German rule: if Roman numerals or letters appear in the numbering, then a point should appear at the end of the numbering.

If you add an appendix the chapter numbering restarts with letter A. If the default KOMA-Script option numbers=auto is active, the dot at the end of all numbers (chapter, section, figure etc.) is added in the next run. To avoid this behavior change the value of option numbers to noenddot:

\documentclass[
  numbers=noenddot% <- added; default value is auto
]{scrbook} 
\usepackage{appendix}
\begin{document}
\chapter{Chapter}
\section{Section}
\begin{appendices} 
\chapter{Appendix Chapter}
\section{Appendix Section}
\end{appendices}
\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.