1

more like a "Bug"-Report, but maybe anyone knows a good workaround?

I use latest texMaker on Mac, with biblatex and using \parencite{}. It seems the spellchecking ignores everything before the \parencite{}.

See example Image, marked text gets ignored and after \parentcite{} it works.

parentcite and spellchecking, texMaker

EDIT: Thanks for the quick response! Here are some more minimal tests.

testing various methods

Texmaker 5.0.2

Packages:

\usepackage[english]{babel}

\usepackage[latin1]{inputenc}

\usepackage[]{multicol}

\usepackage[nameinlink,noabbrev, english]{cleveref}

\usepackage{blindtext}

and a few PDF Packages, if needed I can give full list.

Cheers Hannes

  • If you can consistently reproduce this you should definitely report this to the TeXmaker developers. – moewe Aug 2 '18 at 19:22
  • added more Information, could be related with this spell-check-not-working-in-parts-of-texmaker-after-copy-and-paste – Hannes Oberreiter Aug 2 '18 at 20:19
  • I see, I can reproduce the behaviour now as well. The developers should definitely know about this, submit a bug report even if you do get a work-around here. – moewe Aug 2 '18 at 20:24
  • Ok did send TeXmaker a short mail, thanks for testing it. – Hannes Oberreiter Aug 2 '18 at 20:27
  • As an aside: You should not be using \\ to end a paragraph. In fact you should not be using \\ outside a table or other special environments ever - \\ in normal text are almost always a really bad idea. You start a new paragraph by leaving a blank line in the code or with \par if you insist. If you don't like the paragraph indentations, there are ways to get rid of it, but open any book on your desk and you have a 87% chance that it uses paragraph indents and not vertical space to mark new paragraphs. – moewe Aug 2 '18 at 20:50
2

This seems to be a bug in TeXmaker's spell checking engine. TeXmaker seems to more or less consistently ignore all text in a line leading up to a \cite... like command if there is a \cite... command in a line. The OP has already reported this to the developers and has been promised a fix for the next release in late August or September.

A few possible work-arounds

  • The spell checking will kick in again if one of the two optional arguments is given (it may be empty), so you can write \cite[]{sigfridsson} instead of \cite{sigfridsson} and should be good.
  • Some \cite commands don't suffer from this behaviour, \citep for example is fine. So with natbib compatibility mode (Is there a disadvantage to using natbib=true with biblatex?) you can trick TeXmaker into working again.
  • Move each \cite into a new line
  • Use a different editor. TeXStudio is similar to TeXmaker and is more customisable in many respects. See also LaTeX Editors/IDEs
\documentclass[british]{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{babel}
\usepackage{csquotes}

\usepackage[style=authoryear, backend=biber, natbib]{biblatex}

\addbibresource{biblatex-examples.bib}

\begin{document}
lorem amen lorem amen lorem \textit{sigfridsson} lorem

lorem amen lorem amen lorem \cite{sigfridsson} lorem

lorem amen lorem amen lorem \parencite{sigfridsson} lorem

% work-around 1
lorem amen lorem \cite[]{sigfridsson} lorem

% work-around 2
lorem amen lorem \citep{sigfridsson} lorem

% work-around 3
lorem ipsum lorem
\cite{sigfridsson}
\end{document}

screenshot of TeXmaker with spellcheck enabled

  • Got following Mail answer devs of maker: It will be fixed in the next release (end of august or september) Best regards. – Hannes Oberreiter Aug 3 '18 at 5:16
  • @HannesOberreiter Thanks for reporting this. I edited that into the answer. – moewe Aug 3 '18 at 5:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.