2

I'm trying to make slides for a course I'm teaching this coming semester using beamer and I have a nagging issue with an overfull vbox that I can't diagnose when using the metropolis theme. Here is the minimal example. Note, I'm using pdflatex (for microtype features):

% !TEX program = pdflatex
% !TEX spellcheck = en_US

\documentclass[aspectratio=169]{beamer}

% Font Settings

\usepackage[english]{babel}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[autostyle,english=american]{csquotes}
\usepackage[sfdefault,scaled=0.85,lf]{FiraSans}
\usepackage[scaled=0.85]{FiraMono}
\usepackage{newtxsf}
\usepackage[protrusion,expansion,kerning,spacing,final]{microtype}
\microtypecontext{spacing=nonfrench}

% PDF Bookmarks

\usepackage{bookmark}

% Beamer Setup

\usetheme{metropolis}
\usecolortheme{owl}

% AMS Math Packages

\usepackage{amsmath}

\title{A minimal example}
\date{\today}
\author{Matthias Vogelgesang}
\institute{Centre for Modern Beamer Themes}
\begin{document}
    \maketitle %<-- here is where i get an "Overfull \vbox (15.63992pt too high)"
    \section{First Section}
    \begin{frame}{First Frame}
        Hello, world!
    \end{frame}
\end{document}

I basically pulled this example from the package documentation but included my own preamble. To my knowledge I have the current version of all packages except for babel (which is at 3.18 on my system).

  • 1
    I don't get any error messages … – current_user Aug 3 '18 at 1:44
  • 1
    I also do not get an error when I compile with pdflatex, but I do get one with xelatex. However, as you are saying you use pdflatex I cannot reproduce the issue either. – marmot Aug 3 '18 at 2:05
  • 1
    An overfull vbox is not an error, it is a warning and as such you can (mostly) ignore it. – TeXnician Aug 3 '18 at 6:16
2

The theme is not very careful regarding spurious spaces. If one removes the one from the titlepage definition the warning disappears (but there are more ...):

\documentclass[aspectratio=169]{beamer}

% Font Settings

\usepackage[english]{babel}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[autostyle,english=american]{csquotes}
\usepackage[sfdefault,scaled=0.85,lf]{FiraSans}
\usepackage[scaled=0.85]{FiraMono}
\usepackage{newtxsf}
\usepackage[protrusion,expansion,kerning,spacing,final]{microtype}
\microtypecontext{spacing=nonfrench}

% PDF Bookmarks

\usepackage{bookmark}

% Beamer Setup

\usetheme{metropolis}
\usecolortheme{owl}

% AMS Math Packages

\usepackage{amsmath}

\title{A minimal example}
\date{\today}
\author{Matthias Vogelgesang}
\institute{Centre for Modern Beamer Themes}
\def\titlepage{%
  \usebeamertemplate{title page}%<---
}
\begin{document}
    \maketitle %<-- here is where i get an "Overfull \vbox (15.63992pt too high)"

    \section{First Section}
    \begin{frame}{First Frame}
        Hello, world!
    \end{frame}
\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.