I've searched around but none of the "fixes" I've found have worked (running installer .bat manually, alternate mirrors, etc). Any help or other resources would be greatly appreciated. Every time I run the installer I get the normal fluff log output with this at the end before it crashes:

Loading http://mirrors.concertpass.com/tex-archive/systems/texlive/tlnet/tlpkg/texlive.tlpdb
xz: (stdin): Compressed data is corrupt
Installing TeX Live 2018 from: http://mirrors.concertpass.com/tex-archive/systems/texlive/tlnet (verified)
Platform: win32 => 'Windows'
Distribution: net  (downloading)
Using URL: http://mirrors.concertpass.com/tex-archive/systems/texlive/tlnet
Directory for temporary files: C:\Users\fewr\AppData\Local\Temp\NzH1K9lEZQ
Installing to: C:/texlive/2018
Installing [0001/3638, time/total: ??:??/??:??]: 12many [376k]
tar: Skipping to next file header
untar: untarring C:\Users\fewr\AppData\Local\Temp\NzH1K9lEZQ\IZqygHcgBk/12many.tar failed (in C:/texlive/2018/texmf-dist)
TLPDB::_install_package: untar failed
Installation failed.


EDIT: I tried using basic, advanced, custom, exe, zip download, and everything in between. I tried multiple mirrors and even making a portable install. Everything crashes with this exact error message.

  • Welcome to TeX.SX! Could you please add some details how you install (basic installer, advanced, custom selection, …)?
    – TeXnician
    Aug 8, 2018 at 6:15
  • @TeXnician I tried using basic, advanced, custom, exe, zip download, and everything in between. I tried multiple mirrors and even making a portable install. Everything crashes with this exact error message.
    – fewr
    Aug 8, 2018 at 6:21
  • Well, the error message says untar failed. Could you check the log of your virus scanner if it has been active and noticed "suspicious files"?
    – TeXnician
    Aug 8, 2018 at 6:27
  • 1
    You shouldn't need to install any other tools sets like Cygwin, etc to install TexLive. Is the problem that you are not running TeXLive's version of "untar," and the version you did run has different command line options or whatever?
    – alephzero
    Aug 8, 2018 at 13:00
  • 1
    @alephzero I tried installing before I had any of those separate tools (Cygwin etc) downloaded and got the same error. One more thing, with the tools installed I did install a working version of TeX Live 2017 from the historical repository.
    – fewr
    Aug 8, 2018 at 19:48

4 Answers 4


I had the same Problem. It was caused by MinGW, more specific by xz from the MinGW Installation. I just renamed the xz.exe (you could probably also just temporarily remove the mingw path from the path env) so the texlive installer wouldnt use it and i later restored it to the original name.

An indicator could be the detailed output of the installer (install-tl-windows -gui text -v -no-cls). At the beginning the installer is looking for the setup programs. If you see a line like this:

D:trying to set up system xz, arg --version
D:program xz found in the path*

and also have a line like tar: Skipping to next file header (indicates that the tar is corrupt) at your previous error output/log this might will fix your issue. You can verify the usage of the shipped xz by looking at the detailed output again - it should print (after renaming the other(MinGW) xz.exe) something like this:

D:program xz not usable from path
D:(w32) trying to set up xz, default I:/tlpkg/installer/xz/xz.exe, arg --version
D:Using shipped I:/tlpkg/installer/xz/xz.exe for xz (tested).*
  • 1
    MinGW is something similar to cygwin. My Description is probably not complete or wrong but it is kind of a linux-like environment. I`m simply using it to have linux-tools like gcc and grep available under Windows. Both Cygwin and MinGW usually contain xz and are present in the Path Env and thus the texlive installer will use not its own xz which could lead to the described problem. Hope this helps.
    – TingelJ
    May 7, 2019 at 3:11
  • 2
    Had been chasing this forever. This did it with TL 2019 on windows 10. Remove references to mingw on your path variables.
    – Ernesto
    Jul 13, 2019 at 17:02

Let's see ... this has worked (for me) most of the time:

  1. Let's go to the execute menu and type %temp% and delete ALL ... the same from the "administrator" account, that is, we clean the system's temporary ones and the failed installation folders in C:\

  2. Download (compress file) from install-tl.zip and unzip it.

  3. We enter the folder and with the right mouse button on install-tl-advanced we click using "run as administrator" ...
  4. You wait between one and two hours and ... ready..HapyTex

If this happens to fail ... download dvd version and repeat the steps ... always keeping in mind that we must have permission to administer the installation.


It seems to be the problem of access level. I encountered the same problem, I inspected my temporary folder (%tmp%) and found no tar file was copied to this folder and the installer tried to extract from nothing, the "extract" will certainly fail. Then I found my temp folder is set to read-only, but I cannot uncheck the read-only check box somehow, cause after clicking OK button, it becomes read-only again. Anyway I gave it up and continued my journey with MikTeX, everything work fine now. Perhaps it's a stupid idea to copy files from a full installation DVD to a temp folder for extraction. I decided to rewrite the awkward installer before reusing them.


I had exactly the same issue, and had been searched for solutions for a day. The point raised in the comments by @TingeJJ and @Ernesto indeed worked. So I propose it as a solution.

I removed C:\MinGW\msys\1.0\bin from the PATH system variables. Then everything went smoothly by just using the bat file in the iso image.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .