2

I am not quite sure, what happened, but I was working on some equations, and all of a sudden, TexStudio became buggy. It automatically writes all I write in the \begin{} statement in greek letters (see screenshot). If I look at the .tex file in gedit or in overleaf, everything is normal, but Texstudio just sets greek, and also interprets it like greek (so pdflatex fails). screenshot of small example code This bug does also seem to be with every document I want to work with in TexStudio. I am using TeXstudio 2.6.6 (hg 4099), Qt Version 4.8.6, compiled with Qt 4.8.4 D.

\RequirePackage[ngerman=ngerman-x-latest]{hyphsubst}
\documentclass[numbers=noenddot,11pt,ngerman,english]{scrbook}%{report}
\usepackage{todonotes}
\usepackage{showkeys} % remove for final version
\usepackage{subfiles} %for mother/child nesting of the document
\usepackage{xcolor}
\usepackage{natbib} %citation style from journal template

\begin{document}document
\begin{equation} %Equation
a = b+c 
\end{equation}
\begin{table} %table
\begin{tabular}{ll} %tabular
a&b \\
\end{tabular}
\end{table}
\huge{TEST} 
\renewcommand{\arraystretch}{1.4}
\bibliographystyle{plainnat}
\end{document}

This it the code e.g. in gedit

Maybe someone can help me to fix this?

  • 2
    texstudio has a bug tracker: github.com/texstudio-org/texstudio/issues. Report such issues there. – Ulrike Fischer Aug 14 '18 at 13:18
  • Before you do, update your TXS to the latest version first (2.12.10) and see if the bug persists. – Troy Aug 14 '18 at 13:29
  • I was able to reproduce this with Options > Configure TeXstudio... > Syntax Highlighting, then check for environment under Basic highlighting. The Font Family is probably set to a different font than <default>. – Max Aug 14 '18 at 13:33
  • @Max thank you, you were right. If you want to, change your comment to an answer and I can mark the question as solved – user857813 Aug 14 '18 at 13:38
2

This is probably due to a setting in Options > Configure TeXstudio... > Syntax Highlighting. Check for environment under Basic highlighting. The font family there is probably set to a font with Greek letters, instead of <default>.

In my (Windows) version this looks like:

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.