3

This is a bit related to my earlier post:

Getting correct section numbering for Appendix in a large document

I'm building a thesis with separate articles. I have a file main.tex and an introduction file intro.tex, and 2 articles article1.tex and article2.tex. I'm showing here below the main.tex with the intro and article 1 only:

\begin{document}
some codes for the first few pages
\include{intro}

some code for some intermediate pages

\begingroup

\renewcommand{\appendix}{%
  \par
  \setcounter{section}{0}%
 \renewcommand{\thesection}{\thechapter.\Alph{section}}%
}

\include{article1}

\endgroup
\end{document}

In intro.tex, I have at the end:

\bibliography{lic}
\bibliographystyle{unsrt}

and in article1.tex, I have at the end:

\bibliography{mybibs1}
\bibliographystyle{unsrt}

The compilation is fine but I see that after article 1 in the pdf file, that the Bibliography lic appears instead of mybibibs1. Intro is followed by Bibliography lic as expected but to my surprise, I get Bibliiography lic also after article 1. And of course I'm getting [?] at every referencing throughout article 1.

What's going wrong here?

1

I put \usepackage{chapterbib} and now it works fine. Any other solutions are welcomed also. Could we do that with multibib also?

I'm accepting my own answer in absence of other answers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.