0

I work with the latest ClassicThesis package and realized the TOC shows my entries too close to the title "CONTENT". I would like to have some more space between the title and the first entry of the TOC.

TOC Space under Title

You can even see it if you run a very simple document based on the newest ClassifThesis package. This is so massive, I hardly understand what control commands are set. It has so many parameters! No chance for me to strip it all down to the one critical parameter... Over the last days, I tried to understand it how I could shift down the content of the TOC under its title. To do so, I tried adding

\renewcommand{\cftaftertoctitleskip}{3em}

as well as

\setlength{\cftaftertoctitleskip}{3em}

However, this gets just ignored... =( I would be glad to receive any hint what to do. Thank you!

  • Welcome to TeX.SX! Please help us help you and add a minimal working example (MWE) that illustrates your problem. Reproducing the problem and finding out what the issue is will be much easier when we see compilable code, starting with \documentclass{...} and ending with \end{document}. – BambOo Aug 17 '18 at 15:29
  • Did you try \setlength{\cftaftertoctitleskip}{3em} ? – BambOo Aug 17 '18 at 15:29
  • Thank you - I did try with \setlength{\cftaftertoctitleskip}{3em} , however no impact visible. It seems to be ignored somehow. – Christopher Aug 17 '18 at 16:18
  • Actually I had a look at this one and guess it might lead me to a solution... tex.stackexchange.com/questions/323890/… However, I just have no insight into the large ClassicThesis package to see where the remove the title option... ? – Christopher Aug 17 '18 at 16:40
  • Please add a MWE so we can help, otherwise we're just shooting in the blind – BambOo Aug 17 '18 at 17:27
1

If your document starts with a chapter instead a part, add

\AtBeginDocument{\addtocontents{toc}{%
  \protect\vspace{\dimexpr\cftbeforepartskip-\cftbeforechapskip\relax}%
}}

to the preamble.

Example:

\documentclass{scrreprt}
\usepackage{blindtext}
\usepackage{classicthesis}[2018/06/03]
\AtBeginDocument{\addtocontents{toc}{%
  \protect\vspace{\dimexpr\cftbeforepartskip-\cftbeforechapskip\relax}%
}}
\begin{document}
\tableofcontents
\blinddocument
\part{A Part}
\blinddocument
\end{document}

Result:

enter image description here

  • Totally working fine for me. I digged deeper into your commands, especially the "dimexpr" which is new to me. Thank you so much - your help is awesome here on this forum. Respect ! – Christopher Aug 19 '18 at 20:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.