1

This question is related to this Xelatex try lo load russian package if I use only ukrainian In the case of the text in Russian everything is working, but it is necessary to indicate the Ukrainian language:

\documentclass[a4paper, openright, 12pt]{extreport}
\usepackage[left=15mm,right=85mm,top=15mm,bottom=20mm]{geometry}
\usepackage[main=ukrainian,english]{babel}    %% загружает пакет многоязыковой вёрстки
\usepackage{fontspec}                         %% подготавливает загрузку шрифтов Open Type, True Type и др.
\usepackage{indentfirst}
\usepackage{titlesec,titletoc}
\usepackage[final]{microtype}


% -------------- Настраваем шрифты -----------------------------
\setmainfont[StylisticSet=1]{Old Standard}% Основной шрифт текста
\defaultfontfeatures{Scale=MatchLowercase}

% ================ Настройка некоторых параметров =================|
\parindent=25pt %------------------------------Отступ первой строки|
% -----------------------------------------------------------------|

\clubpenalty=10000
\widowpenalty=10000
\tolerance=600

\hfuzz=0.2pt
%\makeatletter
%\renewcommand{\@chapapp}{Розділ}
%\makeatother

\overfullrule=1mm
\begin{document}
\author{Богдан Тертишний}
\title{Зимові розповіді}

\chapter{}

Але щоб ви з....

Але ми цураємось....

\end{document}

but it is necessary to set the Ukrainian language:

\usepackage[main=ukrainian,english]{babel} 

I get an error

{\Ukrainian \CYRR \cyro \cyrz \cyrd \cyrii \cyrl } 1.

! LaTeX Error: Command \CYRR unavailable in encoding EU1.

See the LaTeX manual or LaTeX Companion for explanation.
Type  H <return>  for immediate help.
 ...                                              

l.36 \chapter{}

But \chapter*{} instead \chapter{} works.

Babel-Ukrainian is installed.

  • 3
    Your system is not up-to-date. EU1 encoding has been replaced by TU for at least two years. Your example (with ukrainian as main language) compiles fine for me. – Ulrike Fischer Aug 18 '18 at 19:42
  • @UlrikeFischer You mean OS? I use Fedora 28. That I need to update? – Игорь Aug 18 '18 at 19:46
  • 3
    No. I mean your tex system. – Ulrike Fischer Aug 18 '18 at 19:47
3

The error message indicates that you have an outdated tex system. I get similar errors with texlive 2016 and older.

With a current texlive 2018 your example compiles without errors:

enter image description here

  • How can I update TEX? sudo dnf update texlive* don't help. – Игорь Aug 19 '18 at 10:15
  • Maybe I don't have some necessary package? – Игорь Aug 19 '18 at 10:17
  • If you want a new texlive you probably will have to install a vanilla tex tug.org/texlive. The tex systems in the linux distribuations are often outdated. And no you don't have a problem with missing packages, your packages are outdated. The babel support for xelatex has improved a lot in the last years. If you don't want to update you could try polyglossia instead of babel, it is older. – Ulrike Fischer Aug 19 '18 at 10:25
  • Of course, I can update the system. I can also wait until the update in the Linux repositories. But how was the question resolved in 2016? – Игорь Aug 19 '18 at 19:07
  • You can get the new version of ukrainian.ldf from ctan ctan.org/tex-archive/macros/latex/contrib/babel-contrib/… and compare it with yours but I doubt that the information is usefull for your. At the end you will simply need a lot of newer files to use babel with xelatex and ukrainian. – Ulrike Fischer Aug 19 '18 at 19:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.