0

I am trying to typeset a document with only Type 1 fonts in the resulting PDF. I'm using the MinionPro package, which calls MnSymbol for math fonts. Even though the Type 1 MnSymbol fonts are installed in ~/texmf/fonts, pdfLaTeX insists on using pk files and producing Type 3 fonts in the PDF output. (I can see this by looking at the log file and the PDF in Evince.)

Here is a MWE:

\documentclass {minimal}

\usepackage {MnSymbol}
\usepackage[T1]{fontenc}

\begin{document}
First, some text. 
Now some math:
$ a^2 + b^2 = c^2.$
\end{document}

The same problem is produced by replacing MnSymbol with MinionPro, and it's worth noting that the log file shows Type 1 Minion Pro fonts files when I do that. So MnSymbol seems to be the problem. More evidence for this: if I use no math symbols in the document, all fonts in the PDF are Type 1.

I have found this similar question, but the solution proposed there (i.e., run updmap) does not seem to work for me. (Perhaps that problem was specific to MikTeX; I'm running a slimmed-down version of TeX Live on a Linux machine.)

A related troubling fact is that MnSymbol.map is nowhere to be seen in the output of updmap-sys --listmaps, though MinionPro.map is. So I'm not even sure how pdfLaTeX is finding MnSymbol in the first place.

Any suggestions?

  • I can't reproduce your problem with an up to date TL2018. pdffonts tells me, that only type 1 fonts were embedded in your MWE. Maybe you should use your the (TL or MiKTeX) package manager to (re)install MnSymbol... – DG' Aug 18 '18 at 20:27
  • Perhaps you could post the (relvant) part of your log file and the output of pdffonts. – DG' Aug 18 '18 at 20:32
  • 1
    What happens if you add \pdfmapfile{=MnSymbol.map} to your document? – Ulrike Fischer Aug 18 '18 at 20:32
  • @UlrikeFischer: That seemed to fix it! I'm very pleased to have an all-Type-1 pdf, but I'd love to know why that works, and what about my setup has caused this annoying problem. – Z Norwood Aug 18 '18 at 20:35
  • 1
    Yes, map files must be enabled with updmap-sys. Normally today this is done by the package managers when they install a package, but sometimes there can be an error. – Ulrike Fischer Aug 18 '18 at 21:02
2

The map-file of the font has not been enabled correctly for an unknown reason.

Run on a command line

 updmap-sys --enable Map=MnSymbol.map

(this is for a texlive system, in miktex it works a bit differently).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.