1

I was using Sharelatex a few days ago and I made some changes to my file, compiled it and I saved my file as PDF. It has all the figures and plots I used via the svg package. Today I tried to open Sharelatex to make some changes again and I got lots of errors. One for every svg figure I have used and it says:

main.tex, line 136
 Package svg Error: File `fig1_svg-tex.pdf' is missing.
 See the svg package documentation for explanation.
 Type  H <return>  for immediate help.
 ...                                              
 l.136 \includesvg[scale=0.335]{fig1.svg}
 Did you run the export with Inkscape? There's no file ./svg-inkscape/fig1_svg-tex.pdf'

I have not changed anything, the \usepackage{svg} line is still on the top of the document and my svg files are still there without name changes. I tried uploading them again and it didn't help.

  • 1
    Welcome to TeX.SX! I don't know ShareLaTeX that well, but does is allow you to run with shell escape because this is required for automatic execution of the conversion? – TeXnician Aug 19 '18 at 7:47
  • 1
    @jinkouishiki said, in an answer: I have the exact same issue. I did not change anything and suddenly all my svg files are not displayed with the same error. – Harald Hanche-Olsen Aug 19 '18 at 9:41
  • 1
    Try to reproduce the issue in a small example document and alert ShareLaTeX staff. If this really worked before and does not any more they should be able to figure out what the problem is. – moewe Aug 19 '18 at 11:31
  • @TeXnician No, I don't think it does really. It doesn't have that many options. The straightforwardness and easy sharing are the main reason I have been using it. – Alireza Aug 19 '18 at 11:44
  • @moewe Tried it in a new project and got the same error. Reported the issue. – Alireza Aug 19 '18 at 12:02
1

Yesterday I had setup a MWE and reported it to Sharelatex. My MWE is :

\documentclass{article}
\usepackage[notransparent]{svg}

\begin{document}
\includesvg[width=1.5cm,height=1.5cm]{info}
\end{document}

The info.svg file was an icon publicly available on the Fontawesome website, but any svg file named "icon.svg" in the top-level folder would work. My setup looked like the image below

An image of my setup, with 2 files document.tex and info.svg and the code displayed above bein presented


Update 20 Aug 2018, 8:30 (UTC+2)

This morning, I tried my MWE again and it compiled. So I'd say that the issue was solved by Sharelatex team. this internal Sharelatex issue looks solved.

Result is inline with expectation :

The result shows the image info.svg being displayed.

|improve this answer|||||
  • 1
    Hi, John from Overleaf/ShareLaTeX here: yes, it was a bug, sorry. It should be fixed now. Thanks for reporting this. – jdleesmiller Aug 20 '18 at 14:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.