1

I get some strange behavior when trying to display a translator in my biblography. The german "Übers. v." is set to a a "V" with two dots above it.

I think it happens due to the latin language which is loaded by polyglossia ans which is later needed in the document. If I remove \setotherlanguage[variant=classic]{latin} all is fine. But I don't really understand why biblatex doesn't simply use the mainlanguage? Has anyone an idea how this could be solved?

Here's my MWE and my Bibliography file:

\documentclass[11pt, pagesize=false]{scrbook}
\usepackage{fontspec}

\usepackage{polyglossia}
    \setdefaultlanguage{german}
    \setotherlanguage[variant=classic]{latin}
    \setotherlanguage[variant=ancient]{greek}

\setmainfont[Numbers=OldStyle]{TeX Gyre Pagella}

%Bibliographie und Abbildungen
\usepackage[style=authoryear,backend=biber, isbn=false]{biblatex}
\bibliography{test-Biblio}

%BEGIN DOCUMENT
\begin{document}
\nocite{bruni_interpretatione_2008}
\printbibliography

\end{document}

And the bib file:

@book{bruni_interpretatione_2008,
    Address = {Ottawa},
    Author = {Bruni, Leonardo},
    Date-Added = {2018-08-27 12:05:41 +0200},
    Date-Modified = {2018-08-27 12:05:41 +0200},
    File = {Katalog plus - Universit{\"a}tsbibliothek Freiburg:/Users/moritzheffter/Library/Application Support/Zotero/Profiles/yc5solgb.default/zotero/storage/U95MWV98/Results.html:text/html},
    Isbn = {978-2-7603-3037-5},
    Keywords = {Quelle},
    Langid = {german},
    Publisher = {Les Presses de l'Univ. d'Ottawa},
    Series = {Collection {Regards} sur la traduction},
    Title = {De interpretatione recta -- {De} la traduction parfaite},
    Translator = {Le Blanc, Charles},
    Year = {2008}}
  • Can you add a picture of the output? I get i.stack.imgur.com/iqZnb.png which looks OK. What versions of biblatex and polyglossia are you running? – moewe Aug 27 '18 at 10:19
  • 1
    Ahh I see, I compiled with LuaLaTeX. Do you compile with XeLaTeX? This quite probably has to do with github.com/reutenauer/polyglossia/issues/172 – moewe Aug 27 '18 at 10:22
  • Yes you are right it's variant classic in the latin package that causes the problem. I'm compiling with XeLaTeX. And after removing the variant all looks fine. I think I'll simply drop the variant. Thanks a lot for your help! – mxordn Aug 27 '18 at 10:32
  • You may want to check out whether babel instead of polyglossia is enough for you. polyglossia development has stalled in recent years (case in point: the 100+ unaddressed bug reports on GitHub) and babel development got back on track. While polyglossia was the go-to recommendation for non-Latin scripts back in the day, babel has made some huge improvements there. If you only have German, Latin and Greek, babel might well be enough for you. polyglossia support in biblatex is also not entirely great: tex.stackexchange.com/q/432347/35864 – moewe Aug 27 '18 at 11:02
2

This is caused by a bug in polyglossia reported in January 2017: https://github.com/reutenauer/polyglossia/issues/172 The bug only occurs with XeLaTeX, LuaLaTeX is not affected.

latin.ldf erroneously sets \classicuclccodes (defined as \def\classicuclccodes{\lccode`\V=`\u \uccode`\u=`\V}) in the current scope whenever the language is loaded with variant=classic or variant=medieval. But the \uccode and \lccode should only be redefined within the language extras and should be cleaned up afterwards (like in gloss-classiclatin.ldf) so that they only apply to Latin text and not to other languages as well.

Here the problem was that biblatex needs \uppercase/\MakeUppercase for automatic capitalisation of "übers. von" with the wrong settings active the "ü" is converted to a "V" with two dots above.

If you don't need the "U/V" feature of polyglossia you can turn it off after you load latin with an explicit variant option (and indeed every time you explicitly request a Latin variant) with \noclassicuclccodes.

\documentclass[11pt, pagesize=false]{scrbook}
\usepackage{fontspec}

\usepackage{polyglossia}
    \setdefaultlanguage{german}
    \setotherlanguage[variant=classic]{latin}
    \noclassicuclccodes % work around https://github.com/reutenauer/polyglossia/issues/172
    \setotherlanguage[variant=ancient]{greek}

\setmainfont[Numbers=OldStyle]{TeX Gyre Pagella}

\usepackage[style=authoryear,backend=biber, isbn=false]{biblatex}

\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@book{bruni_interpretatione_2008,
    Address = {Ottawa},
    Author = {Bruni, Leonardo},
    Isbn = {978-2-7603-3037-5},
    Keywords = {Quelle},
    Langid = {german},
    Publisher = {Les Presses de l'Univ. d'Ottawa},
    Series = {Collection {Regards} sur la traduction},
    Title = {De interpretatione recta -- {De} la traduction parfaite},
    Translator = {Le Blanc, Charles},
    Year = {2008}}
\end{filecontents}

\addbibresource{\jobname.bib}

\begin{document}
\nocite{bruni_interpretatione_2008}
\printbibliography
\end{document}

Bruni, Leonardo (2008). De interpretatione recta – De la traduction parfaite. Übers. von Charles Le Blanc. Collection Regards sur la traduction. Ottawa: Les Presses de l’Univ. d’Ottawa.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.