I updated my system to Ubuntu 18.04 and now I've got problems with TeXstudio.

The error message looks like this


I did try to reinstall texstudio (a lot times) and run all the purge and cleaning commands, but it simply doesn't work …

I did run the following commands:

sudo apt-get --purge remove texstudio
sudo apt-get update
sudo apt-get install texstudio

In between I did reboot the system, too. I visited the official website and tried the .deb packages for earlier versions of Ubuntu, but it was useless.

Does anybody have an idea? Can anybody please help me out?

  • Did you try it with the synaptic (→ sudo apt-get install synaptic) app to completely remove TeXStudio with all configurations and so on? Aug 28, 2018 at 3:41
  • 1
    @current_user: I did it, too, but it doesn't work. I saw (in an eralier post from you that) you're using Ubuntu, too. Which version do you have? How can I get more attention to this question? Aug 28, 2018 at 3:59
  • I don't think that you can get more attention to this question. Did you tried it on other forums (e.g. on some german ones)? Maybe there you are better helped, since that is not directly related to TeXStudio. Yes, I've got the same problem and I'm just waiting for a solution like you … Aug 28, 2018 at 4:02
  • Crosspost
    – Johannes_B
    Aug 28, 2018 at 4:59
  • Which latex distribution are you using? How did you install it on Ubuntu?
    – henry
    Aug 28, 2018 at 6:00

3 Answers 3


Same problem here after upgrading to Ubutnu 18.04.1 LTS.

Removing the .config/texstudio/texstudio.ini file helped.

  • 2
    Welcome to TeX - LaTeX! Oct 11, 2018 at 9:34
  • Probably it help by accident, as it doesn't reliably help (e.g. in my case, Linux Mint, TeXstudio 2.12.6 (from the distro)).
    – uli_1973
    Mar 15, 2019 at 9:55

Try this from the terminal. For me it worked. Before running this go to the required directory where the deb file is located.

sudo apt-get remove --auto-remove texstudio
sudo apt-get update
sudo dpkg -i texstudio-qt4_2.12.6-2_amd64.deb

I had few additional issues where the icons were not displaying. So I did the following:

sudo apt-get install libpoppler-qt4-4
sudo apt-get install libqt4-svg

If the above doesn't work, try removing texstudio completely with all its dependencies using Synaptic Package Manager and do a reinstall.

  • 1
    Thank you. But it says "memory access error". Aug 27, 2018 at 17:34
  • 1
    try removing texstudio completely using synaptic package manager.
    – creative
    Aug 28, 2018 at 4:02
  • 1
    I did it, but it the error is still there … Aug 28, 2018 at 4:11

After upgrade to Xubuntu 18.04 texstudiu wasn't working and showing the meory violation like described above... Installing Texstudiu for qt4 from http://download.opensuse.org/repositories/home:/jsundermeyer/xUbuntu_17.04/amd64/texstudio-qt4_2.12.10-2_amd64.deb using dpkg works for me.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.