I have a LaTeX file which includes a PDF image file as follows


I can compile this without any problems using pdflatex. But when I include the package hyperref and a bunch of other packages, it gives me the following error:

File 'chapter1/figure/image.bb' not found. ...dth]{chapter1/figure/image.pdf}
Cannot determine the size of graphic in chapter1/figure/image.bb (no BoundingBox). ...dth]{chapter1/figure/image.pdf}

migrated from stackoverflow.com Feb 16 '12 at 21:19

This question came from our site for professional and enthusiast programmers.

  • 5
    This may be a very localized problem. Could you post the PDF image somewhere so that users can have access to it? It would also be preferable to supply an minimal working example (MWE) required to reproduce the problem. For example, would using graphicx and hyperref in the `article document class be sufficient to reproduce your problem (given the image/PDF)? – Werner Feb 16 '12 at 21:25
  • I am using the template found in here link with the necessary package driver modifications. since there are many files in the template, I am not sure how to post a MWE. – gunan Feb 20 '12 at 3:43

You are most likely calling graphicx with a specific driver option not compatible with the compiler/graphics format. For example

\usepackage[dvipdfm]{graphicx}% http://ctan.org/pkg/graphicx

Remove this option and let graphicx do its own thing of figuring out the required graphics driver.

Alternatively, if all else fails, you could also try supplying the correct bounding box as option:

\includegraphics[bb=llx lly urx ury]{image}

where llx lly urx ury denotes the lower-left (x,y) and upper-right (x,y) coordinate of the image in bps (big points).

  • Already tried the package driver option with no success. Also, I just tried supplying bounding box manually, which also did not work.All of the files and figures had no problems with any other template (oxford university press templates, for example) – gunan Feb 20 '12 at 3:48
  • @gunan: This should not be a template problem, but rather something to do with either your TeX distribution, or the image itself. Do the following: (1) Post your entire preamble (including document class) as an edit to your original post and (2) include what is posted after **File List** in your .log file after you add \listfiles before \documentclass; (3) perhaps upload a problem image somewhere and post a link to it. Without any of this information, it would be hard to assess what the problem is. – Werner Feb 20 '12 at 6:16
  • In my case it was necessary to comment-out the whole line "\usepackage{graphicx}" – user22360 Nov 20 '12 at 20:13
  • I have the same problem, but graphicx is not included in any of my style files. I guess it's nested way down? Is there any way to un-include it? – Doctor Mohawk Sep 22 '13 at 6:04
  • 1
    @mohawkjohn: Sometimes you load a package that loads graphicx as a dependency since it does form part of the "required" packages. If you add \listfiles to your document preamble, you'll see a **File List** in your .log, from which you can trace the dependencies of packages/files loaded by corroborating the list with the loading order in your own preamble. Anything that is not listed in the preamble is loaded as a dependency of another package. – Werner Sep 22 '13 at 14:36

I found this page when encountering a similar problem. I didn't have graphicx explicitly loaded, but I was including epsfig. When I moved the usepackage{hyperref} below epsfig, everything worked as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.