5

As far as I know latexmk automatically defines what to do when running it. So compile it several times that all references are correct.

However this takes a loooong time when I just want to check my table. Is there any way to disable this automatic behaviour and say that it just should run pdflatex once and then show the result?

In arara, for example, this is possible.

13
  • 4
    You could just run pdflatex -pdf texfile.tex instead of latexmk. Commented Aug 28, 2018 at 18:56
  • 3
    I was looking fou using the feature of latexmk -pvc to run in the background so everytime i save he rund pdflatex automatically. However till now he is doing it several times then
    – SRel
    Commented Aug 28, 2018 at 19:01
  • 1
    I do not think the comparison with arara is fair. arara does what you tell it to do, latexmk tries to read your mind (and the LaTeX files) and decides on its own.
    – TeXnician
    Commented Aug 28, 2018 at 20:06
  • 3
    IF you have a good PDF viewer (not Adobe Acrobat) you can start looking at the PDF after the first run, while latexmk is stll doing its thing. And to answer the OP's actual question, you can do latexmk -e "$max_repeat=n" ... where n is the maximum number of passes it makes before it gives up (the default is 5).
    – alephzero
    Commented Aug 28, 2018 at 21:03
  • 1
    @alephzero Would you like to convert your comment into an answer? Commented Sep 13, 2018 at 9:18

1 Answer 1

4

With

latexmk \$max_repeat=<n>

you can limit the number of runs latexmk does to <n>. By default, it is 5. Search for “max_repeat” in the latexmk documentation for further information. FWIW, I call latexmk with the -pvc option, and hitting the limit triggers only a warning but latexmk does not abort. It stops calling the LaTeX processor but continues watching for changes in the input files.

Note that you might need to quote the $ differently (or not at all) in your environment.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .