2

I want to install the Document Class that the journal "Frontiers in Physics" requires. (Note: LyX does not list such a class as 'unavailable' [and, so answers to similar questions may not pertain]. In any event, I tried to follow advice in one of those answers. See below.)

I downloaded the template file via https://www.frontiersin.org/journals/physics#author-guidelines and http://www.frontiersin.org/design/zip/Frontiers_LaTeX_Templates.zip.

I followed (several times) the process that How to Install an Unavailable Document Class for LyX on Windows recommends. Once, I did the following.

  1. I created a folder (which I named Frontiers) under Program Files (x86) > MikTeX 2.9 > tex > latex. (I seemed to need to use Windows ‘Admin privileges’ to do this.)

  2. I extracted all the material from the folder Frontiers_LaTeX_Templates into the folder Program Files (x86) > MikTeX 2.9 > tex > latex > Frontiers.

  3. I ran MikTeX 2.9 > Settings (Admin), and triggered (first) ‘Refresh FNDB’ and (second) ‘Update Formats.’

  4. I ran LyX -> Tools -> Reconfigure.

  5. I closed LyX

  6. I restarted LyX, specified File -> New, and then tried Document -> Settings.

  7. I looked at the drop-down list under ‘Document Class’.

  8. I did not find anything that I could associate with ‘Frontiers’. (I looked – in the drop-down list - especially at ‘Articles’ [including items listed as ‘Unavailable’] and at ‘Uncategorized’.)

On later tries, I added (and then extracted into) the folders … Program Files (x86) > MikTeX 2.9 > tex > Frontiers … and … Program Files (x86) > MikTeX 2.9 > tex > latex > lncs > Frontiers.

For various (including all but the first) attempts, between steps between steps 2 and 3, I tried to do … Windows System -> Command Prompt -> C:\Users\test>texhash. This appeared to report two lines of ‘successful’ activity and two lines of ‘perhaps not successful’ activity. Here is a 'scape' of the last such report.

C:\Users\test>texhash
Creating fndb for user root directory (C:\Users\test\AppData\Roaming\MiKTeX\2.9)...
Creating fndb for user root directory (C:\Users\test\AppData\Local\MiKTeX\2.9)...
Skipping common root directory (C:\ProgramData\MiKTeX\2.9)...
Skipping common root directory ("C:\Program Files (x86)\MiKTeX 2.9")...

I would like advice as to how to get this to work successfully.

  • I wish I had more advice, but you've already tried what I would have suggested. The first thing would be to figure out is whether it is a LyX problem. Can you compile a document manually (e.g. from a LaTeX editor or on the command line), outside of LyX, that uses the new document class? If so, then it would suggest a LyX problem. Note that a new version of LyX, LyX 2.3.1, should be released in a few days. Good luck! – scottkosty Aug 28 '18 at 22:27
  • scottkosty: Thank you. Unfortunately, I do not know how to do the presently possible activities you suggest. (All my experience with TeX is via LyX. (Perhaps this is a strange thing to say, given that I am a years-ago co-author of papers with Don Knuth, who [later, I think] developed TeX. But, so be it.) Perhaps, please advise regarding how to do 'compile a document manually (e.g. from a LaTeX editor or on the command line), outside of LyX, that uses the new document class' (You would need to tell me how, e.g., to connect with such an editor.)? In any event, with appreciation. - Tom – TJB Aug 29 '18 at 0:04
  • Ah I see. Not strange, but interesting! I'm sorry, but I have no experience with Windows. I can tell you how to create a .tex file: In LyX, just start a new document and type e.g. "hello world". Then go to File > Export > LaTeX (pdflatex). Then a .tex file will be created in that directory. I'm not sure how to get to the command line on Windows, but if you get here, you can run the command "pdflatex <yourfile.tex>". – scottkosty Aug 29 '18 at 0:29
1

You have to create a *.layout File for Lyx, in which you define, which class and wich style is to be used. Find here further information: https://wiki.lyx.org/Layouts/Layouts

  • MRMuenster: Thank you. I tried to do such and discovered that the Frontiers zip file apparently does not include a .layout file. I wrote to Frontiers. My email to them points to your answer. Let's see what happens. (Hopefully, soon, I will have more info for you and other people.) - Tom – TJB Aug 31 '18 at 21:04

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.