0

reference for book section is not showing properly where the book section title is missing:missing before in

\documentclass[11pt,a4paper,twoside,openright,titlepage,fleqn,%
               headinclude,footinclude,BCOR5mm,%
               numbers=noenddot,cleardoublepage=empty,%
               captions=tableheading]{scrreprt}

\usepackage[utf8]{inputenc}
\usepackage[english]{babel}
\usepackage[style=nature, 
  citestyle=authoryear, 
  backend=biber, 
  natbib=true, 
  uniquename=false, 
  date=year,
  url=false,
  doi=false, 
  isbn=false,
  mincitenames=1]{biblatex}
\addbibresource{biblio.bib}

\begin{document}
this is not showing properly
\citep{CASESMITH2006}

\printbibliography
\end{document}

in biblio.bib:

@incollection{CASESMITH2006,
address = {Massachusetts},
author = {Case-Smith, Jane},
booktitle = {Hand Function in the Child},
chapter = {Hand Skill},
doi = {10.1016/B978-032303186-8.50010-1},
edition = {2},
editor = {{Henderson, Anne; Pehoski}, Charlene},
isbn = {9780323031868},
pages = {117--141},
publisher = {Elsevier},
title = {{Hand Skill Development in the Context of Infants' Play: Birth to 2 Years}},
url = {http://linkinghub.elsevier.com/retrieve/pii/B9780323031868500101},
year = {2006}
}
  • I will check in a few minutes, but I can tell you already that editor = {{Henderson, Anne; Pehoski}, Charlene}, is very wrong. It should be editor = {Henderson, Anne and Pehoski, Charlene},. Names must always be separated with and, see tex.stackexchange.com/q/36396/35864 – moewe Aug 29 '18 at 9:01
  • @moewe I do notice that about the naming, but Mendeley generated the naming automatically and it's quite annoying to change it everytime I update my list of references – Sharah Aug 29 '18 at 9:17
  • Ugh, Mendeley. There should be a way to input the name so that it is exported correctly. If there is not you should contact the developers and complain about that. The output you get now is seriously broken and wrong. – moewe Aug 29 '18 at 9:28
1

By default biblatex-nature suppresses titles of @inbook/@incollection entries. You can get the titles back with intitle=true for @inbook and @incollection.

Incidentally, there is a similar setting for titles of @article entries. articletitle=true is the default and displays article titles, but with articletitle=false you can suppress them.

See also the biblatex-nature documentation about articletitl and intitle.

Note that the name format of the editor field was incorrect (see How to properly write multiple authors in bibtex file?) and that normally the chapter field holds a numeric value (the chapter number) and not a (shortened) copy of the chapter title.

I would also like to mention that the combination of authoryear citation style and (numeric) nature bibliography style is not particularly fortunate. In a long bibliography with many entries it might be quite hard to find an entry from its author-year label since the year is located near the end, while the author name is at the front. The numbers in the bibliography also have no connection to anything else in the document and just add visual noise, in fact I believe they distract from the author name and make things harder to find.

\documentclass{article}

\usepackage[utf8]{inputenc}
\usepackage[english]{babel}
\usepackage[style=nature,
%  articletitle=false,
  intitle=true,
  citestyle=authoryear,
  backend=biber,
  natbib=true,
  uniquename=false,
  date=year,
  url=false,
  doi=false,
  isbn=false,
  mincitenames=1]{biblatex}

\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@incollection{CASESMITH2006,
  address   = {Massachusetts},
  author    = {Case-Smith, Jane},
  booktitle = {Hand Function in the Child},
  chapter   = {7},
  doi       = {10.1016/B978-032303186-8.50010-1},
  edition   = {2},
  editor    = {Henderson, Anne and Pehoski, Charlene},
  isbn      = {9780323031868},
  pages     = {117--141},
  publisher = {Elsevier},
  title     = {Hand Skill Development in the Context of Infants' Play: Birth to 2 Years},
  year      = {2006}
}
\end{filecontents}

\addbibresource{\jobname.bib}
\addbibresource{biblatex-examples.bib}

\begin{document}
this is not showing properly
\citep{CASESMITH2006,sigfridsson}

\printbibliography
\end{document}

Case-Smith, J. *Hand Skill Development in the Context of Infants’ Play: Birth to 2 Years* in *Hand Function in the Child* (eds Henderson, A. & Pehoski, C.) 2nd ed., 117–141 (Elsevier, Massachusetts, 2006).

Note finally that you were using outdated and deprecated options to scrreprt, you should see warnings about that in the .log file.

  • Interesting. However, I get this error /usr/share/texlive/texmf-dist/tex/latex/biblatex/biblatex.sty:11970: Package ke yval Error: intitle undefined. – Sharah Aug 29 '18 at 9:19
  • @Sharah In that case you are using an outdated version of biblatex-nature. The option was added in version 1.3 from October 2016: github.com/josephwright/biblatex-nature/commit/… Make an update. – moewe Aug 29 '18 at 9:21
  • Since I am using Overleaf, is there's a way to use the latest version of biblatex-nature? – Sharah Aug 29 '18 at 9:22
  • @Sharah Well biblatex-nature only really consists of nature.cbx and nature.bbx. I assume you could get them from ctan.org/tex-archive/macros/latex/contrib/biblatex-contrib/… and upload them with your project. This might work, but it could also go wrong in case biblatex-nature uses some new features of biblatex that the version of Overleaf does not support yet. – moewe Aug 29 '18 at 9:23
  • I see. Alright I will find some work to go around that. Anyway, what do you mean by outdated and deprecated options to scrreprt? I do not see any warning – Sharah Aug 29 '18 at 9:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.