My appendix style looks like this:

%  \coversheet{\uppercase\expandafter{\@@appendixname}}  % REMOVE COVERSHEET

Then in the main tex file I have:


In the appendix1 tex file I have:

\chapter{Flooding Test Graphs}

The actual appendix page title looks fine, but the TOC looks like this:


I would like it to say:


There are similar questions and answers posted, but I still can't seems to get it to work.

On the last line of the style file I tried:


This just writes "APPENDIX" over "A FLOODING TEST GRAPHS"

  • the \renewcommand{\appendix}{\par ... \Alph{chapter}} seems to be missing a } in your example... is that in your code too?
    – henrique
    Feb 17, 2012 at 12:18
  • This response helped, but it's not quite what I need yet. I need the whole word Appendix to be capitalized in the Table of Contents. Right now, only the "A" is capitalized. Also, when I use the appendices environment, it puts the word APPENDIX followed by a number above the chapter heading for each chapter even if the chapter is not in the Appendix. Do you know how to solve this problem?
    – user12216
    Feb 29, 2012 at 23:27

1 Answer 1


Use \usepackage[titletoc]{appendix} and then use the appendices environment:

enter image description here

\usepackage[titletoc]{appendix}% https://ctan.org/pkg/appendix
    \chapter{A chapter} \chapter{A chapter} \chapter{A chapter}

        \chapter{An appendix} \chapter{An appendix}
  • 3
    Note that adding \usepackage{appendix} isn't sufficient. You need to use the titletoc option (or specify \appendixtocon). Merely using \appendix also does not suffice; use the appendices environment.
    – Werner
    Feb 18, 2012 at 16:32
  • 3
    This fails if you \include{} the appendix as a seperate file. using \input{appendixfile} fixes that issue.
    – Johan
    Nov 29, 2018 at 12:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy