2

When I put the option \useinnertheme[shadow]{rounded}, there is this fatal error :

LaTeX Error: Option clash for package beamerinnerthemerounded.

When commenting on this line, %\useinnertheme[shadow]{rounded} the shadow is square!

The code:

\documentclass[aspectratio=1610,10pt]{beamer} % Présentation générale et mise en page
\usetheme{Warsaw}
\usecolortheme{default}
\useoutertheme{infolines}
%\useinnertheme[shadow]{rounded}
\setbeamertemplate{navigation symbols}{\insertframenavigationsymbol}
\author{By me}
\institute{Junior High School}
\title {Some }

\begin{document}
\maketitle
\end{document}

The result :

beamer-shadow-rounded

Edit: Copy of the beginning of the log file

    This is pdfTeX, Version 3.14159265-2.6-1.40.19 (MiKTeX 2.9.6800 64-bit) (preloaded format=latex 2018.8.31)  31 AUG 2018 19:06
entering extended mode
**./test-dev.tex
(test-dev.tex
LaTeX2e <2018-04-01> patch level 5
("C:\Program Files\MiKTeX 2.9\tex\latex\beamer\beamer.cls"
Document Class: beamer 2018/08/22 v3.51 A class for typesetting presentations
("C:\Program Files\MiKTeX 2.9\tex\latex\beamer\beamerbasemodes.sty"
  • Your beamer version seems to be outdated. With the code as it is in your question, I get a rounded shadow: i.stack.imgur.com/UptIi.png And you don't need \useinnertheme[shadow]{rounded}, this is what Warsaw already loads. – user36296 Aug 31 '18 at 16:57
  • @samcarter I updated MikTeX yesterday, how is that possible? – AndréC Aug 31 '18 at 17:03
  • Can you add \listfiles to your preamble and look into your log file which beamer version you have? Current one is 3.51 – user36296 Aug 31 '18 at 17:04
  • @samcarter I got version 3.51! – AndréC Aug 31 '18 at 17:08
  • How are you compiling? pdflatex or some other engine? – user36296 Aug 31 '18 at 17:09
2

There are two different problems involved:

  • If you have beamer version 3.51: compiling with latex and subsequently converting to pdf does not work well for elements which contain transparency. Workaround: compile directly to pdf with pdflatex or use one of the other engines.

  • As long as there is an error message, there is also no point in looking at what might or might not be valid pdf. Luckily the error can easily be solved by removing the line \useinnertheme[shadow]{rounded} -- it is not necessary at all because the Warsaw theme already loads it with the option shadow=true

  • Now I have another incomprehensible error: this document which is very long (24 slides) and contains many images (57), tikz code and ocg layers... I compiled it a week ago on my laptop with Windows 10 without problem and now on the other desktop with Windows 10 it no longer compiles completely. I don't know how to do this anymore! I wonder if it might be a Windows 10 problem? – AndréC Aug 31 '18 at 18:42
  • @AndréC Can you show the error message you get? – user36296 Aug 31 '18 at 18:52
  • line 1 Package etex Warning: Extended allocation already in use. – AndréC Aug 31 '18 at 18:55
  • @AndréC On the first glance this looks like a warning. But can you copy the complete message from the log file somewhere which preserves lines breaks, e.g. into your question? – user36296 Aug 31 '18 at 19:00
  • The log is here pastebin.com/rdMfejGp – AndréC Aug 31 '18 at 19:07
1

Try \useinnertheme[shadow=true]{rounded}:

\documentclass[aspectratio=1610,10pt]{beamer} % Présentation générale et mise en page
\usetheme{Warsaw}
\usecolortheme{default}
\useoutertheme{infolines}
\useinnertheme[shadow=true]{rounded}
\setbeamertemplate{navigation symbols}{\insertframenavigationsymbol}
\author{By me}
\institute{Junior High School}
\title {Some }

\begin{document}
\maketitle
\end{document}

This compiles with no errors.


The reason is that the Warsaw theme declares the following:

\useinnertheme[shadow=true]{rounded}

So loading \useinnertheme[shadow]{rounded} would lead to option clash. However, to be honest, you don’t need to specify \useinnertheme[shadow]{rounded} or \useinnertheme[shadow=true]{rounded}.

BTW, if I commented out \useinnertheme[shadow=true]{rounded}, the shadows still are rounded. You probably need to check if your beamer class is updated properly.

  • The shadow is not rounded, but there is no more error. – AndréC Aug 31 '18 at 17:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.