0

I would like to add working papers in my biblatex chicago bibliography. I would like list the working paper series and the paper's number. However, chicago style drops any reference to the working paper series.

Setup:

I am using biblatex-chicago with the following setup

\documentclass[12pt]{scrbook}
\usepackage[authordate,
isbn=false,
url=false,
doi=false,
maxcitenames=3,
maxbibnames=10,
block=space,
backend=biber]{biblatex-chicago}

Previous posts:

I have found two workarounds, which both dont work for me. One manual one Link 1 that uses reports. This solution prints technical report in the bibliography which is undesirable. The other one is this one, that is manual and would create a lot of manual effort in my >200 page dissertation document. Link 2

Any help would be much appreciated!

Edit per request by Moewe:

I receive

Bagger, Jesper, Javier a Birchenall, Hani Masnsour, and Sergio Urzúa. 2013. Education, Birth Order, and Family Size. Technical report. Institute for the Study of Labor - IZA Discussion paper series

and I would like to receive:

Bagger, Jesper, Javier a Birchenall, Hani Masnsour, and Sergio Urzúa. 2013. Education, Birth Order, and Family Size. Working Paper No. 7454, Institute for the Study of Labor - IZA Discussion paper series: [or something similar]

Full configuration

\documentclass[12pt]{scrbook}
\usepackage{a4wide}
\usepackage{fancyhdr}    
\usepackage{graphicx}
\usepackage{textgreek}
\usepackage{float} % better control over placement of tables and figures in the text
\usepackage{xcolor}
\usepackage{url}
\usepackage[hidelinks]
\usepackage{pdflscape}
\usepackage{afterpage}
\usepackage{marvosym}
\usepackage{epstopdf}
\usepackage{setspace}
\usepackage{amsmath,amssymb}
\usepackage[american]{babel} 
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{csquotes}
\usepackage{setspace}
\addtokomafont{disposition}{\rmfamily}
\usepackage[authordate, backend=biber]{biblatex-chicago} 
\bibliography{../../library}
\hypersetup{
colorlinks=true,
linkcolor=blue,
anchorcolor=blue,
citecolor=blue,
filecolor=blue,
menucolor=blue,
runcolor=blue,
urlcolor=blue
}

\setlength{\bibitemsep}{0.5em} 
\setlength{\bibhang}{3em}
\renewbibmacro{in:}{}

\renewcommand{\labelnamepunct}{\addcomma\space} 

\finalandcomma 
\usepackage{xpatch}

\xpatchbibmacro{volume+number+eid}{%
setunit*{\adddot}%
}{%
}{}{}

\AtBeginBibliography{% 
\renewcommand*{\mkbibnamelast}[1]{\textsc{#1}}%
\renewcommand*{\mkbibnamefirst}[1]{\textsc{#1}}%
\renewcommand{\mkbibnameprefix}[1]{\textit{#1}}
\renewcommand{\mkbibnameaffix}[1]{\textsc{#1}}
}
\usepackage[left=1.1in, right=1.1in, bottom=1.1in]{geometry}

\begin{document}

\printbibliography

\end{document}
  • 1
    The solution from tex.stackexchange.com/questions/325842/… does not print the words 'technical report' in the bibliography for me, I get exactly the output as shown in the answer. What exactly did you try (please provide a full example document similar to what you find in the linked answer), what output did you get (show a picture) and what did you expect instead? – moewe Sep 3 '18 at 12:09
  • Note that the behaviour of biblatex-chicago is slightly non-standard here. The standard styles only support type and number, while biblatex-chicago supports type, series and number. – moewe Sep 3 '18 at 12:11
  • I think that the difference is that mendeley prints at_technicalreport and not _atreport. Here is an excerpt of the bibliography @techreport{Bagger2013, author = {Bagger, Jesper and Birchenall, Javier a and Masnsour, Hani and Urz{\'{u}}a, Sergio}, booktitle = {IZA Discussion paper series}, title = {{Education, Birth Order, and Family Size}}, volume = {No. 7454}, year = {2013} } – Maximilian S. Sep 3 '18 at 12:26
1

It seems Mendeley exports an entry like this

@techreport{Bagger2013,
 author = {Bagger, Jesper and Birchenall, Javier a and Masnsour, Hani and Urz{\'{u}}a, Sergio},
 booktitle = {IZA Discussion paper series},
 title = {{Education, Birth Order, and Family Size}},
 volume = {No. 7454},
 year = {2013}
}

Ideally you would use @report instead of @techreport, but @techreport is fine as well.

@reports should always have a type field. That field can hold the paper series or any other useful type specification. If @techreports don't have a type field biblatex will substitute "technical report" instead; this is not the case for @report entries.

The number in a series goes into number and not volume.

booktitle is completely ignored.

A useful entry would look like

\documentclass[english]{article}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage{babel}
\usepackage{csquotes}
\usepackage[authordate,
isbn=false,
url=false,
doi=false,
maxcitenames=3,
maxbibnames=10,
block=space,
backend=biber]{biblatex-chicago}

\usepackage{filecontents}
\begin{filecontents*}{\jobname.bib}
@techreport{Bagger2013,
  author      = {Jesper Bagger and Javier A. Birchenall and Hani Mansour and Sergio Urzúa},
  title       = {Education, Birth Order, and Family Size},
  date        = {2013-06},
  type        = {IZA Discussion paper},
  number      = {7454},
  institution = {Forschungsinstitut zur Zukunft der Arbeit},
  location    = {Bonn},
}
\end{filecontents*}
\addbibresource{\jobname.bib}

\begin{document}
\cite{Bagger2013}

\printbibliography
\end{document}

Bagger, Jesper, Javier A. Birchenall, Hani Mansour, and Sergio Urzúa. 2013. Education, Birth Order, and Family Size. IZA Discussion paper 7454. Bonn: Forschungsinstitut zur Zukunft der Arbeit, June.

| improve this answer | |
  • Thank you - incredibly helpful - this solved my problem. For other users: Report type and number are not available by default when you add a report document type to your library. You can add type/number/etc. as categories via Tools > Options > Document Details. Mendeley does not export the Number into the .bib files but for me it also works to add the number to the "Type" of document. Moewe - you are the most helpful seagull out there. Thanks again! – Maximilian S. Sep 3 '18 at 13:46
  • @MaximilianS. Not that I am very confident that it will help, but you should contact the Mendeley developers about this. If they claim to support biblatex they really should allow type and number for @report or @techreport. Type is even a mandatory field. – moewe Sep 3 '18 at 14:54
  • They do so for at_techreport. Mendeley does not export at_report (imho). However, while I can enter for example Number : 14013, it is not exported into the bibliography file, which is strange, because Mendeley even exports the abstract by default ... I shall send them our finding. Thanks again for your support. – Maximilian S. Sep 3 '18 at 15:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.