1

I want to put my glossary at the end of my document. I succeeded to do that. But the problem is within the table of contents (TOC): It shows the glossary twice (at the beginning and at the end).

It appears at:

  1. the begining because of "\loadglsentries" (I am using an external file): code_part1
  2. the end where I placed "\printglossary" while using the option "toc" with the "glossaries" package: code_part2

My question is: how could I just show the glossary at the end of TOC, in its right place?

Thank you and sorry (it is my first post!)

Table of contents_1 Table of contents_2

  • That's not normal behaviour. Perhaps you have \addcontentsline line somewhere in your document that's confusing things. (You also have two bibliography entries for page 45, so there seems to be some duplication in your document.) – Nicola Talbot Sep 5 '18 at 18:06
  • @NicolaTalbot , yes, I had two entries for the bibliography because I used \addcontentsline and added the "tocbibind" package. I solved it by adding the option 'notbib" like this: \usepackage[nottoc,notbib,notindex]{tocbibind}. For the glossary, I checked the whole code (main.tex) but there is no \addcontentsline for it. Finally I checked my glossary.tex and surprise! There is an \addcontentsline for the glossary! I spend hours on this problem. Really, thank you very much ! – Lyes Sep 6 '18 at 7:35
1

The problem was the presence of another \addcontentsline for the glossary in the glossary.tex file in addition of the one I'd put in the main.tex.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.