1

The background to this question is that I am a freelance typesetter working on the second edition of a book that I first typeset six years ago. I have a new computer now, but I made sure to copy over the files from my localtexmf folder, so I should in theory have all the font files I need to run the second edition.

I am running MikTeX 2.9 on Windows 10 with UI Winedt 10.1 and dvi viewer Yap. When I run the book files and view the dvi, I receive error messages about fonts not being loadable. Details are seen going to Yap > File > Document Properties. All of the fonts producing errors end in "8r"; I feel that this cannot be a coincidence. Does anyone have an idea what might be going on and how I might fix it?

Here is a small working sample:

\documentclass{article}

\usepackage{offsans}
\usepackage{kabel}
\usepackage{mathptmx}

\begin{document}

Hello in Officina Sans.\\

\textbf{Hello in Officina Sans bold.}\\

\textit{Hello in Officina Sans italic.}\\

$Hello\ in\ math\ mode$\\

\textsf{Hello in Kabel.}\\

\end{document} 
  • What happens if you compile with pdflatex? Do you get errors there too? – Ulrike Fischer Sep 9 '18 at 18:02
  • 1
    Do you know where your offsans and kabel packages came from? Are they accessible on the internet? I can't see them on CTAN. – Thruston Sep 9 '18 at 18:47
  • The 8r ending is used for the ISO8859-1 encoding with post script type one fonts. So I guess that you must have had ..8r versions of your special fonts somewhere, (probably in your localtexmf tree that you have preserved), but that your local psmap file does not know about them. You might have to refresh the font map file so that all the various bits of tex software can find your fonts. – Thruston Sep 9 '18 at 18:50
  • Does this help? tex.stackexchange.com/questions/74698/… – Thruston Sep 9 '18 at 18:53
  • To answer some of the questions, the offsans and kabel packages were created by a third party, generating the required LaTeX structure from the system font files. I guess that doesn't really help you …. And when I run the file in PDFLaTeX, I get the fatal error "!pdfTeX error: pdflatex.exe (file ikbk8r): Font ikbk8r at 600 not found". I am going to try the instructions in the provide link. – Charlotte B Sep 10 '18 at 14:07
1

According to your code the book was typeset using the fonts "Officina Sans". This fonts is only available for money.

But probably you already got the necessary fonts files ending *.pfb on your harddrive. And fortunately on CTAN is a package which will help you to get a running installation, see here: https://ctan.org/pkg/w-a-schmidt

The files are here: https://ctan.org/tex-archive/fonts/psfonts/w-a-schmidt and I guess your Officina Sans will work after installing the lo9 package, see here for instructions: https://ftp.uni-erlangen.de/ctan/fonts/psfonts/w-a-schmidt/lo9.txt

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.