13

I'm using the beamer class and would like to remove the indentation created for items in the itemize environment.

I have tried the following solutions:

  • the enumitem usepackage - just loading it removes all bullet points entirely
  • \setlength{\itemindent}{-1em} before the item. It only removes the indentation of the first line of an item, but if the item is multi-lined, the other lines are still indented.

This is my MWE:

\documentclass{beamer}
\usepackage[utf8]{inputenc}

\begin{document}
\begin{frame}{Frame Title}
Some text
\begin{itemize}
%\setlength{\itemindent}{-1em}
    \item first item
    \item this is a second item which is longer and should hopefully go over more than one line
\end{itemize}
\end{frame}
\end{document}
1

1 Answer 1

22

Is this the layout you are looking for?

\documentclass{beamer}
\usepackage[utf8]{inputenc}

\begin{document}
\begin{frame}{Frame Title}
Some text
\settowidth{\leftmargini}{\usebeamertemplate{itemize item}}
\addtolength{\leftmargini}{\labelsep}
\begin{itemize}
    \item first item
    \item this is a second item which is longer and should hopefully go over more than one line
\end{itemize}
\end{frame}
\end{document}

enter image description here

8
  • 2
    This is exactly what I am looking for, thanks very much!
    – Jaran
    Commented Sep 11, 2018 at 6:59
  • 1
    @Jaran You're welcome! Commented Sep 11, 2018 at 8:14
  • 1
    I even used \addtolength{\leftmargini}{\labelsep -.75cm} to make it wider without needing to widen the column environment !
    – ygorg
    Commented Mar 17, 2022 at 18:03
  • 1
    can we make this setting globally for all the itemize ?
    – alper
    Commented Jan 9, 2023 at 15:43
  • 1
    @shafee You're welcome! Have fun with beamer :) Commented Feb 26, 2023 at 18:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .