1

On Ubuntu 18.04.1 I installed texlive-publishers to be able to use ieeeconf.cls in one of my documents, but when I run pdflatex mypaper.tex it asks for the file, which I've found to be located in "/usr/share/texlive/texmf-dist/tex/latex/IEEEconf/IEEEconf.cls"

Now, I have to manually enter that location every time I want to compile my document, and though I have found that a solution would be to simply copy the cls file in question to the directory of my tex file, I don't find the solution adequate. Is there some way I can specify a $LATEX_HOME or some other way that I can let pdflatex know where my cls library is?

Sorry for asking a platform specific question, I know this is a tex stackexchange but please help me, you're my only hope.

  • Welcome to TeX.SX! Does it work if you store the class file in the same folder like the main file. – Bobyandbob Sep 11 '18 at 11:19
  • Normally pdflatex should find such files if /usr/share/texlive/texmf-dist is a tree of your tex system and if you run mktexlsr. – Ulrike Fischer Sep 11 '18 at 11:21
  • Excuse me @UlrikeFischer but what do you mean "is a tree of your tex system"? I ran the command and it seemed to update fine: mktexlsr: Updating /usr/local/share/texmf/ls-R... mktexlsr: Updating /var/lib/texmf/ls-R-TEXLIVEDIST... mktexlsr: Updating /var/lib/texmf/ls-R-TEXMFMAIN... mktexlsr: Updating /var/lib/texmf/ls-R... mktexlsr: Done. but still pdflatex still asks for the file as it cannot be found. I'm sure it's there though. – simernes Sep 11 '18 at 11:34
  • But mktexlsr seem not to update /usr/share/texlive/texmf-dist/ so this tree seems not to belong to your tex system. – Ulrike Fischer Sep 11 '18 at 12:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.