0

I am writing a research paper in latex template which has some figures in EPS format. While compiling the template I see a blank box instead of figure I'm not getting why it's happening

I have used

\usepackage{epstopdf}

in the preamble but still, it doesn't work. Any guess why it's happening.

Code

\begin{figure*}
\includegraphics[width=1\textwidth]{figs/Fig1}
\caption{Experiment results for D=250}
\label{Figure:exp_250}
\end{figure*}

Output

enter image description here

I am using Kile in Ubuntu.

1
  • 4
    what you show is the output from [draft] mode. Note you should not have to use epstopdf package these days Sep 13 '18 at 14:50
1

You probably have not enabled \write18 which allows LaTeX to call external programs. From the documentation:

The feature \write18 must be enabled. This allows the running of external programs during TEX’s compile run. Keep in mind that this is a security risk. The feature is an addition to \TeX. MikTEX, teTEX, TEX Live support it. In Web2C based TEX distributions (teTEX, TEX Live) it can be enabled in the configuration file texmf.cnf: shell_escape = 1

Simply call e.g. pdflatex with the --shell-escape should do the trick. In Kile you need to edit the command via Settings => Configure Kile => Build

7
  • 4
    eps to pdf conversion is allowed without shell-escape these days (so long as the epstopdf package isn't loaded and the core graphics package code is used (which uses a restricted version of epstopdf allowed in that context) Sep 13 '18 at 14:51
  • 1
    Hello @UweZiegenhagen, I have changed the command in Settings => Configure Kile => Build from PDFLaTeX+ViewPDF to LaTeX + DVItoPDF + ViewPDF. Now I can see the figure but Caption is appearing at left of the figure instead of the bottom. s33.postimg.cc/ksdd1vn33/plot2.png
    – Atinesh
    Sep 13 '18 at 15:06
  • What happens if you just use the figure, not figure* environment? AFAIK is is used in two-column typesetting. Sep 13 '18 at 15:38
  • @UweZiegenhagen Problem still persists. The figure is wide I need to show it in 2 columns.
    – Atinesh
    Sep 13 '18 at 16:38
  • Are you using the draft option for your documentclass? Sep 13 '18 at 17:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.