1

I am trying to work on a thesis following a template from my university, and I am having trouble making a 'Nomenclature' and 'Symbols' list. I am able to successfully make a 'Glossary' and 'Abbreviations' list, but for some reason I can't get the first two to work. I get the following message on each page where the Nomenclature and Symbols list should be:

Error message.

I've looked inside the .nomenclature-glo file, and there is an entry in there (the same way there is one for the lists that work). The same goes for the .symbols-glo file. I've made sure that the 'glossaries-extra' package is part of my distribution and is installed..as far as I can tell, that isn't the problem because the Abbreviations list is working (which is also part of the extras package). I am using Texpad on MacOS and I have tried the following settings:

Texpad settings.

By default (when I have Auto-Sense on), only 'Glossaries' is enabled. However, changing this setting also did not help. I have also noticed that Texpad recognizes only two index runs in my document, when I imagine that there should be four: Number of indices.

I've tried to search all over for this issue but haven't been able to find another post with a similar issue. Any help would be greatly appreciated! This is the code that I am working with:

% Define Glossary terms (This is properly done here, in the preamble. Could be \input{} from a file...)
% Main glossary entries -- definitions of relevant terminology
\newglossaryentry{computer}
{
name=computer,
description={A programmable machine that receives input data,
               stores and manipulates the data, and provides
               formatted output}
}

% Nomenclature glossary entries -- New definitions, or unusual terminology
\newglossary*{nomenclature}{Nomenclature}
\newglossaryentry{dingledorf}
{
type=nomenclature,
name=dingledorf,
description={A person of supposed average intelligence who makes incredibly brainless misjudgments}
}

% List of Abbreviations (abbreviations type is built in to the glossaries-extra package)
\newabbreviation{aaaaz}{AAAAZ}{American Association of Amature Astronomers and Zoologists}

% List of Symbols
\newglossary*{symbols}{List of Symbols}
\newglossaryentry{rvec}
{
name={$\mathbf{v}$},
sort={label},
type=symbols,
description={Random vector: a location in n-dimensional Cartesian space, where each dimensional component is determined by a random process}
}

\makeglossaries
  • This sounds like a Texpad issue not a Tex/LaTeX issue. Texpad has a help forum. Have you asked there? The developer has always responded to my posts, although his responses can take a while. Also, what happens when you compile with TeXShop (it is installed with TeXLive on macOS)? – Jeffrey J Weimer Sep 14 '18 at 1:20
  • @JeffreyJWeimer thank you for your response, I think you might have figured out the exact issue. I tried compiling with TeXShop and all 4 lists show up without any problems. So I guess it must be something with Texpad (that didn't occur to me because I didn't get any errors or warnings or anything like that). Would you kindly be able to point me to the help forum? All I can seem to find on their website are their blog posts and articles, but no options to post a question of my own. – Dave J. Sep 14 '18 at 2:22
  • It seems that TeXPad is explicitly calling makeindex on specific files (those associated with the default main glossary and possibly some of the other predefined glossaries provided by the base glossaries package) but it doesn't include the additional glossary provided by glossaries-extra or any custom glossaries (defined with \newglossary). It would be much better if it just had one tool that used either makeglossaries or makeglossaries-lite. I don't know anything about TeXPad, so I don't know how to change the configuration. – Nicola Talbot Sep 14 '18 at 10:03
  • @NicolaTalbot thank you for your response, you're right that it seems to be an issue with Texpad more than anything else, as Jeffrey pointed out. Now I am just trying to figure out how to contact them about the issue and see what the problem is. – Dave J. Sep 14 '18 at 15:23
  • @DaveJ. If you get a response, it would be great if you could post an answer. I'm trying to accumulate a list of all the various different front-ends and how they run the associated glossary tools. – Nicola Talbot Sep 14 '18 at 18:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.