I get this error each time i use siunitx. I am using siunitx version 2.7s, with miktex and texworks on PC.

enter image description here

% !TEX TS-program = pdflatexmk





Its been pointed out that the key issue may be that I am using an old version of MikTeX (without the console), so the question in part becomes, how do you update MikTex on Windows 8? and are there any problems with doing this?

here is a screenshot of me trying to update MikTex

enter image description here

  • 3
    Please tell us more about the TeX distribution and the version of the siunitx package that are installed on your computer. For what it's worth, I am unable to replicate the issue you describe on my system (MacTeX2018, all updates installed; version of siunitx: 2.7s, date: 2018-05-17). – Mico Sep 15 '18 at 9:48
  • I am using miktex on a pc, how do i check whether my updates are installed? I am using siunitx version 2.7s ? – Abijah Sep 15 '18 at 9:57
  • 1
    When did you last update your MikTeX distribution? – Mico Sep 15 '18 at 10:17
  • I think Siunitx is up to date - i downloaded it for the first time this morning. When I tried to update miktex in response to your comment it failed. I am not sure why - here is a screenshot snag.gy/qwncMJ.jpg – Abijah Sep 15 '18 at 10:49
  • 4
    This error is completely understandable. Judging from the screenshot you still have MikTeX without the console (the MikTeX update manager), which means your MikTeX is definitely not up-to-date, but you threw in an up-to-date package. Therefore I'm retagging this as MikTeX. – TeXnician Sep 15 '18 at 11:27

I had the same problem with the newest Miktex version and the newest update of siunitx.

After wasting too much precious time on this issue, I found a workaround by out-commenting lines 111-258 in siunitx.sty which seems related to some syntax compatibility with older versions:

% \exp_args:NNx \seq_const_from_clist:Nn \c__siunitx_old_options_seq
% {
% ...
% }

The workaround works for me, but I don't know which functionality might be affected.


  • 2
    It's a really bad idea to change the code of a package. This specific piece of code is just to cope with deprecated options of the siunitx package. I'd suggest, if you should insist on changing the package code instead of updating, replacing \seq_const_from_clist:Nn by \seq_gset_from_clist:Nn, which would have (sort of) the same effect. But again: do not change the code of a package. Update! – Phelype Oleinik Feb 5 at 12:36
  • Thanks, this solved the problem for me. – JavAlex Apr 23 at 22:56
  • thanks, for me too (on Debian 9 under TexLive). – Dieter.Wilhelm Aug 23 at 16:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.