3

I'm wondering how can I avoid excessive white space under equation. This happens only a time in the entire document; in the other pages there are not this problem (I wrote the equation and the text in the same way everywhere).

enter image description here

poi saranno applicate quando si collegherà solo il sensore:
\begin{equation*}
H(j \omega) = Z_{Known}(j \omega) \frac{V^{ZK}_{ADC1}(j \omega)}{V_{IN}(j \omega)}
\end{equation*}
dove $V^{ZK}_{ADC1}$ è la tensione letta dall'ADC quando tra il WE1 ed il CE è collegata solo la $Z_{Known}$ (\footnote{Notare che, quando $V^{ZC}_{ADC1}(j \omega) = V^{ZK}_{ADC1}(j \omega)$, si ha: \begin{equation*}
Z_{S}(j \omega) = Z_{Known}(j \omega) \frac{V^{ZK}_{ADC1}(j \omega)}{V_{IN}(j \omega)} \frac{V_{IN}(j \omega)}{V^{ZS}_{ADC1}(j \omega)} = Z_{Known}(j \omega)
\end{equation*}}).
L'impedenza $Z_{Known}$ ha la seguente espressione:

EDIT: I'm using classicthesis template. The documentclass is:

\documentclass[oneside,titlepage,numbers=noenddot,%1headlines,
                headinclude,footinclude,cleardoublepage=empty,abstract=on,
                BCOR=5mm,paper=a4,fontsize=11pt
                ]{scrreprt}

https://ctan.org/tex-archive/macros/latex/contrib/classicthesis?lang=en

Thank you so much in advance.

  • Please tell us which document class you employ, which font-related packages you employ, and whether \flushbottom or \raggedbottom is in effect. Ideally, you would edit your query to provide not just a code fragment but a compilable example that generates the problem behavior you wish to fix. – Mico Sep 16 '18 at 8:26
  • Hello @Mico see the edit please. – Gennaro Arguzzi Sep 16 '18 at 8:34
  • 2
    you have given no indication why the space is there, so hard to tell you what to change. Most likely it is something on the next page preventing a good page break. Your example should be a complete small document that shows the issue so that people can debug – David Carlisle Sep 16 '18 at 8:45
  • 1
    Thanks for providing information about the document class. Do you employ a package such as classicthesis? – Mico Sep 16 '18 at 8:46
  • 3
    The issue is simple to describe: footnote 19 is quite long and wouldn't fit in page 23; so it's moved to page 24 together with one line above and below because you end up with a three line (partial) paragraph. Unless you do some editing, the problem will remain. To begin with, I don't think that material with a displayed equation qualifies as “footnote”. – egreg Sep 16 '18 at 9:05
6

As @egreg has already pointed out in a comment, the big gap at the bottom of page 23 is caused by the fact that the material that follows the first displayed equation contains a lengthy footnote. This material -- including footnote 19 -- just won't fit at the bottom of page 23 and hence gets pushed to the top of page 24.

The following screenshot shows how this can happen (the code is given at the end of this answer):

enter image description here

There are several possible remedies:

  • Make footnote 19 take up less space. E.g., is it essential to include a displayed equation in that footnote? Alternatively, if the footnote material truly is sufficiently important to warrant a displayed equation, it may be sufficiently important to be include in the main text, rather than being relegated to a footnote.

  • Shorten the material earlier on page 23 (or page 22, or ...).

  • Insert an instruction such as \enlargethispage{0.75\baselineskip} (or whatever vertical skip may be necessary...) just before the paragraph that contains the displayed equation.

Any visual fine-tuning should be performed only at the very end of the editing process, i.e., once the paper is truly done from a content perspective.

For the sake of completeness, here's the code that gave rise to the screenshot shown above; note that I would use upright Roman lettering for acronyms and full words, such as 'Known' and 'ADC', that occur in a math context.

\documentclass[oneside,titlepage,numbers=noenddot,
   headinclude,footinclude,cleardoublepage=empty,abstract=on,
   BCOR=5mm,paper=a4,fontsize=11pt]{scrreprt}
\usepackage{amsmath}
\usepackage[dottedtoc]{classicthesis}
\usepackage{lipsum}
\newcommand\vn[1]{\mathrm{#1}} 
\newcommand\myfootnote[1]{%
   \textsuperscript{(}%
   \footnote{#1}%
   \textsuperscript{)}}
\begin{document}
\setcounter{page}{23}
\setcounter{footnote}{17}
\setcounter{chapter}{2}
\setcounter{section}{3}
\section{Confronto tra il biosensore ed un bipotenziostato da banco}

\lipsum[1-2] % filler text
\myfootnote{Calibrare significa sollecitare con ingressi noti e misurare 
le correspondenti uscite. In questo caso gli ingressi noti \dots}
\lipsum[2] % more filler text

% Check out what happens if the following line is uncommented.
%\enlargethispage{0.75\baselineskip}  
\bigskip
\noindent
poi saranno applicate quando si collegherà solo il sensore:
\begin{equation*}
H(j\omega) = Z_{\vn{Known}}(j\omega) \frac{V^{\vn{ZK}}_{\vn{ADC}1}(j\omega)}{V_{\vn{IN}}(j\omega)}
\end{equation*}
dove $V^{\vn{ZK}}_{\vn{ADC}1}$ è la tensione letta dall'ADC quando tra il WE1 ed il~CE è collegata solo la $Z_{\vn{Known}}$.%
\myfootnote{Notare che, quando $V^{\vn{ZC}}_{\vn{ADC}1}(j\omega) = V^{\vn{ZK}}_{\vn{ADC}1}(j\omega)$, si ha: 
\[
Z_{S}(j\omega) = Z_{\vn{Known}}(j\omega) 
\frac{V^{\vn{ZK}}_{\vn{ADC}1}(j\omega)}{V_{\vn{IN}}(j\omega)} 
\frac{V_{\vn{IN}}(j\omega)}{V^{\vn{ZS}}_{\vn{ADC}1}(j\omega)} 
= Z_{\vn{Known}}(j\omega)\,.
\]}
L'impedenza $Z_{\vn{Known}}$ ha la seguente espressione: \dots

\bigskip
\lipsum[4-7] % still more filler texxt
\end{document}
  • 1
    i took a liberty and correct definition of \newcommand\vn[2]{\mathrm{#1}} to \newcommand\vn[1]{\mathrm{#1}} (after that your mwe works). compiling your mwe, i obtain quite different result as shown in your answer. i use recent miktex. – Zarko Sep 16 '18 at 9:31
  • problem seems to be with \myfootnote. if \lipsum[2] is immediately after it, this paragraph not appear, but is printout only [2], i .e. option which paragraph from lipsum should be used. inserting blank lines before repair this malfunction. – Zarko Sep 16 '18 at 9:40
  • @Zarko - Many thanks for applying the fix to the definition of \vn. Something very weird seems to have happened during the copy-and-paste operation: In the tex file on my system, both \vn and \myfootnote are defined to take a single argument. However, upon pasting (and indenting), the two instances of [1] ended up as [2]. I have no idea how this came about. I suspect it's a site bug. Fortunately, both commands now show that they take a single argument. – Mico Sep 16 '18 at 10:08
  • 1
    @Mico Unrelated, but I've been meaning to compliment you on your TUG talk. It was very interesting and you did a perfect job of explaining the linguistics! (I put this comment elsewhere, but I thought it would be better on one of your answers instead of a new user's question.) – Alan Munn Sep 16 '18 at 18:36
  • 1
    @AlanMunn - Wow, thanks so much for this compliment!! I deeply appreciate it. You can probably tell that I'm not a linguist by training (in fact, I'm an economist...), but I did get a thorough introduction to morphemes and morphology from Felix Lehmann, who is a budding linguist, at a crucial early stage of the development of the selnolig package. Felix and his colleague Steffen Hildebrand provided a large number of crucial inputs and validations to the package -- including teaching me the basics of morphology! I very much appreciated getting this type of education. :-) – Mico Sep 16 '18 at 18:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.