1

When I enter ^t on my keyboard (shift+^+t) in texstudio, then the document is compiled without t being written in the editor, leaving the ^ without an argument, resulting in an error. I can work around this by entering (shift+^+space+t) instead. However, other letters do not give me this trouble (e.g. shift+^+s is results in ^s being written to the editor). What is going on?

closed as unclear what you're asking by Troy, Sebastiano, Stefan Pinnow, Mensch, Circumscribe Dec 22 '18 at 23:06

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    This doesn't seem like default behaviour. Do you have any macros set in TXS? Also, please mention what TXS version you are on, what OS and your keyboard layout may also be relevant. Does this also happen if you use default settings ? (with TXS closed, delete / make a backup copy of .config/texstudio.ini and restart TXS.) – Troy Sep 17 '18 at 2:10
  • No macros. TeXstudio 2.12.4 (hg 6476:3e5c3afa4719) Using Qt Version 5.6.2, compiled with Qt 5.6.2 R. Windows 10, swedish keyboard. – Asdf Sep 17 '18 at 2:13
  • 1
    It does not occur if I switch to english keyboard settings. Actually, this change appears to have resolved the problem. – Asdf Sep 17 '18 at 2:21
  • Problem returned. After I do the language switch, if I compile the document, the next ^t will run the compiler again. – Asdf Sep 17 '18 at 2:43
  • Going back to default settings by deleting texstudio.ini with TXS closed and then restarting TXS did not fix it. – Asdf Sep 17 '18 at 2:47

Browse other questions tagged or ask your own question.