1

I use a Windows 10 setup with MiKTeX and I am trying to use xindy for index generation (for use with tex4ebook and the helpers4ht package). The xindy script was installed at the following location:

C:\Users\Jürgen\AppData\Local\Programs\MiKTeX 2.9\scripts\xindy\xindy.pl

However, when I try to compile the files (via the Windows command console), the tex4ebook script breaks off with the following error message:

xindy error

Apparently, the xindy.pl script cannot cope with the Umlaut in my user name. Is there a way around this?

  • What happens if you try to run (in some test folder!) perl "C:\Users\Jürgen\AppData\Local\Programs\MiKTeX 2.9\scripts\xindy\xindy.pl" --help? – Ulrike Fischer Sep 17 '18 at 11:19
  • 1
    I (re)found this question tex.stackexchange.com/q/184822/2388, which allowed me to run a test without changing my user account name: texindy fails for me as soon as a parent folder contains an umlaut. If fails both with texlive and with miktex. Where is your document located? Also in the user account? Can you move it to some folder without any non-ascii chars in the path and try again? – Ulrike Fischer Sep 17 '18 at 12:01
  • You can substitute your user folder to some other drive: "subst y: c:\Users\Jürgen". Then you change to the Y: drive and work there. (Under the assumption that Y: was free initially. Obviously another option would be to switch to a user with Umlaut in it. BTW I can feel your pain. Have a look at my last name to see how I solved the problem once and for all. – Stefan Schroeder Sep 17 '18 at 12:09
  • I sent a question to the texlive list about it tug.org/pipermail/tex-live/2018-September/042369.html. But don't have to many hopes about a real solution. – Ulrike Fischer Sep 17 '18 at 12:23
  • Akira answered on the texlive list and says (what I already suspected) the quite probably xindy-lisp.exe can't handle files with Umlauts. So you should at least relocate your documents to a folder without umlauts in the path. – Ulrike Fischer Sep 17 '18 at 12:54
1

To recap, the problem arose because the xindy_lisp.exe executable invoked by the xindy.pl script cannot cope with Umlauts (or presumably, other special characters) in file and directory names. This post a problem for me, since my username is "Jürgen" and thus many of my files and applications are located in my "C:\Users\Jürgen" folder

Furthermore, even after I removed both my MiKTeX installation and my test .tex file from the "C:\Users\Jürgen" file, the problem persisted. After following advice I had received here, I examined my environmental variables and discovered that both the HOMEPATH and LOCALAPPDATA made use of "\Users\Jürgen", and that xindy_lisp.exe somehow tried and failed to access either or both of these directories (even though there was nothing relevant there).

Thus, I needed to change these environmental variables. However, since I don't know what other software made use of these variables, I wanted the original directories to remain accessible. Thus, I decided to set a hard symbolic link. In the Windows Terminal:

mklink /J C:\User_Juergen C:\Users\Jürgen

This had the added benefit of making the .tex files in my Google Drive accessible to xindy-lisp.exe, since my Google Drive folder was also within my C:\Users\Jürgen hierarchy.

Thus, I set HOMEPATH="\User_Juergen" and LOCALAPPDATA="C:\User_Juergen\AppData\Local", and xindy-lisp.exe ceased to cause a problem.

Thanks to everyone who helped me figure this out!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.