I have a document which has an associated .bib file that is created using Jabref. I include the ful; path to the .bib file in the Latex preamble using the commands:

\makeindex             % used for the subject index
                       % please use the style svind.ist with
                       % your makeindex program



\addbibresource {C:/Users/tkpme/Dropbox/Book PCRM/mpsbookNew.bib}


In the past, I have had no difficulty choosing an item when I wanted to insert a citation. All of a sudden, no citations at all are available to choose from when I click on Insert > Citation! Oddly enough, citations I inserted in the past get processed correctly when I generate a pdf - I just can't insert any new citations.

Any help would be greatly appreciated.

Thomas Philips

  • Where is your main file? (Full path)
    – koleygr
    Sep 19, 2018 at 0:10
  • My main file is in C:/Users/tkpme/Dropbox/Book PCRM/Chapter 18 Sep 19, 2018 at 0:32
  • Try ../mpsbookNew.bib instead. This means to go back to the parent directory (the "..") and look there for the file. See here (the accepted answer): tex.stackexchange.com/questions/249291/…
    – koleygr
    Sep 19, 2018 at 0:43
  • I tried it, and I'm afraid this doesn't work. I had tried this earlier, and found that relative paths didn't work, so I then switched to an absolute path and it worked perfectly for a while. I tried to edit the file again today and couldn't see any available citations in the pop-up window. I'll read your accepted answer and see if there are any hints in there that might be relevant. Sep 19, 2018 at 0:55
  • The answer is not mine there... It is not even belong to its author. The problem is that I can not help because I don't use lyx. Please consider accepting one or more answers on your previous questions to have more possibilities to get help and to offer this way to the community too. I hope someone can help you. The only think I can think, is that may be removing the space from the main folder name would do the trick. But can not test it.
    – koleygr
    Sep 19, 2018 at 0:59

3 Answers 3


Figured it out! At the end of the document I had an TeX box which said BibTeX Generated Bibliography. Once I clicked on that I realized that I had to add a new local database, and I added the database that is sitting in the root directory. Once I did that everything was fine. In summary, I had to fix things in two places - once with the path in the LaTeX Preamble and the second time with the database in the Bibtex Generated Bibliography


I ran into the same problem when my .bib file was in the same folder as my .lyx file. In the "BibTeX Generated Bibliography" dialog I just had to add a "./" in front of the .bib file name.

enter image description here


I had a similar issue. My setup was: Master document (e.g. thesis.lyx) with included child document, where the Bibtex Generated Bibliography resided (e.g. references.lyx). The references were not visible in the Lyx:Citation dialog in the master document nor in other child documents (chapters).
Turned out, setting "Select default master document" in the settings of "references.lyx" to "thesis.lyx" made the difference.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .