1

I have just installed TexLive 2018 on my Linux machine. I try to compile the MWE (see below), but the compilation ended with:

This is pdfTeX, Version 3.14159265-2.6-1.40.19 (TeX Live 2018) (preloaded format=pdflatex)
 restricted \write18 enabled.
entering extended mode
(./test.tex
LaTeX2e <2018-04-01> patch level 5
(/opt/texlive/2018/texmf-dist/tex/latex/base/article.cls
Document Class: article 2014/09/29 v1.4h Standard LaTeX document class
(/opt/texlive/2018/texmf-dist/tex/latex/base/size10.clo))
(/opt/texlive/2018/texmf-dist/tex/latex/base/inputenc.sty)
(/opt/texlive/2018/texmf-dist/tex/latex/base/fontenc.sty
(/opt/texlive/2018/texmf-dist/tex/latex/base/t1enc.def))
(/opt/texlive/2018/texmf-dist/tex/generic/babel/babel.sty
(/opt/texlive/2018/texmf-dist/tex/generic/babel/switch.def)
(/opt/texlive/2018/texmf-dist/tex/generic/babel-slovenian/slovene.ldf
(/opt/texlive/2018/texmf-dist/tex/generic/babel/babel.def
(/opt/texlive/2018/texmf-dist/tex/generic/babel/txtbabel.def))))
(/opt/texlive/2018/texmf-dist/tex/latex/graphics/graphicx.sty
(/opt/texlive/2018/texmf-dist/tex/latex/graphics/keyval.sty)
(/opt/texlive/2018/texmf-dist/tex/latex/graphics/graphics.sty
(/opt/texlive/2018/texmf-dist/tex/latex/graphics/trig.sty)
(/opt/texlive/2018/texmf-dist/tex/latex/graphics-cfg/graphics.cfg)
(/opt/texlive/2018/texmf-dist/tex/latex/graphics-def/pdftex.def)))
(/opt/texlive/2018/texmf-dist/tex/latex/biblatex/biblatex.sty
(/opt/texlive/2018/texmf-dist/tex/generic/oberdiek/pdftexcmds.sty
(/opt/texlive/2018/texmf-dist/tex/generic/oberdiek/infwarerr.sty)
(/opt/texlive/2018/texmf-dist/tex/generic/oberdiek/ifluatex.sty)
(/opt/texlive/2018/texmf-dist/tex/generic/oberdiek/ltxcmds.sty)
(/opt/texlive/2018/texmf-dist/tex/generic/oberdiek/ifpdf.sty))
(/opt/texlive/2018/texmf-dist/tex/latex/etoolbox/etoolbox.sty)
(/opt/texlive/2018/texmf-dist/tex/latex/oberdiek/kvoptions.sty
(/opt/texlive/2018/texmf-dist/tex/generic/oberdiek/kvsetkeys.sty
(/opt/texlive/2018/texmf-dist/tex/generic/oberdiek/etexcmds.sty)))
(/opt/texlive/2018/texmf-dist/tex/latex/logreq/logreq.sty
(/opt/texlive/2018/texmf-dist/tex/latex/logreq/logreq.def))
(/opt/texlive/2018/texmf-dist/tex/latex/base/ifthen.sty)
(/opt/texlive/2018/texmf-dist/tex/latex/url/url.sty)
(/opt/texlive/2018/texmf-dist/tex/generic/xstring/xstring.sty
(/opt/texlive/2018/texmf-dist/tex/generic/xstring/xstring.tex))
(/opt/texlive/2018/texmf-dist/tex/latex/biblatex/blx-dm.def)
(/opt/texlive/2018/texmf-dist/tex/latex/biblatex-apa/apa.dbx)
(/opt/texlive/2018/texmf-dist/tex/latex/biblatex/blx-compat.def)
(/opt/texlive/2018/texmf-dist/tex/latex/biblatex/biblatex.def)
(/opt/texlive/2018/texmf-dist/tex/latex/biblatex-apa/apa.bbx
(/opt/texlive/2018/texmf-dist/tex/latex/biblatex/bbx/standard.bbx))
(/opt/texlive/2018/texmf-dist/tex/latex/biblatex-apa/apa.cbx)
(/opt/texlive/2018/texmf-dist/tex/latex/biblatex/biblatex.cfg))
(/opt/texlive/2018/texmf-dist/tex/latex/biblatex-apa/slovene-apa.lbx
(/opt/texlive/2018/texmf-dist/tex/latex/biblatex/lbx/slovene.lbx)
(/opt/texlive/2018/texmf-dist/tex/latex/biblatex/lbx/slovene.lbx

! LaTeX Error: Missing \begin{document}.

See the LaTeX manual or LaTeX Companion for explanation.
Type  H <return>  for immediate help.
 ...                                              

l.528 }

?

Here is the MWE:

\documentclass{article}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[slovene]{babel}
\usepackage{graphicx}
\usepackage[backend=biber,style=apa,citestyle=apa,hyperref]{biblatex}

\DeclareLanguageMapping{slovenian}{slovene-apa}

%\addbibresource{references.bib}

\title{Title of the document}
\author{}
\date{}

\begin{document}

\maketitle

\section{Test}

Lorem ipsum.

%\printbibliography

\end{document}

It is important to note that the same document compiled just fine with TexLive 2017. I suspect that something is wrong with babel/biblatex settings. I kindly as for any suggestions.

3

There is a missing comma in slovene.lbx that causes this error (specifically in line 481).

The bug has been reported and fixed in version 3.12 of biblatex (released 2018-10-30). An update should resolve the issue.

If for some reason you can not update your biblatex installation. You can get a fixed replacement slovene.lbx for 3.11 from https://github.com/plk/biblatex/blob/b14b013cce98fef41a4f8a19fdf4924facbd87cb/tex/latex/biblatex/lbx/slovene.lbx. Just drop it into the same file as your main .tex document. Note that this version may throw errors with older systems over missing string definitions.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.