0

This is my first message to this forum, and you can consider me as a newbie. I have installed MiKTeX 2.9 on windows 8.1 and I'm using LED as editor. Since I need to write hieroglyphs in a way which is more professional than the standard package provided, I tried to install Hierotex package retrieved by CTAN. Unfortunately when in check the visible packages by the console it does not appear and when I try to use it (quite tricky because it requires to use a support function called sesh) currently it's giving me this error:

enter image description here

Can someone give me an hint on how to overcome this problem and complete the correct installation?

here it is the log content

2018-09-19 15:22:56,181+0200 INFO  miktex-maketfm - starting with command 

line: miktex-maketfm -v Egyp
2018-09-19 15:22:56,213+0200 INFO  maketfm - Running miktex-makemf.exe...
2018-09-19 15:22:56,213+0200 INFO  maketfm - running: miktex-makemf.exe --miktex-enable-installer --verbose Egyp
2018-09-19 15:22:56,435+0200 INFO  maketfm - Running miktex-hbf2gf.exe...
2018-09-19 15:22:56,435+0200 INFO  maketfm - running: miktex-hbf2gf.exe --miktex-enable-installer -g Egyp 300
2018-09-19 15:22:56,662+0200 FATAL miktex-maketfm - No creation rule for font Egyp.
2018-09-19 15:22:56,662+0200 FATAL miktex-maketfm - No creation rule for font Egyp.
2018-09-19 15:22:56,662+0200 FATAL miktex-maketfm - Info: 
2018-09-19 15:22:56,662+0200 FATAL miktex-maketfm - Source: 
2018-09-19 15:2

2:56,662+0200 FATAL miktex-maketfm - Line: 0

I add an additional useful info: it does not appear among the installed packages enter image description here

last finding from my side

% Thomas Esser, 1998, 1999, public domain.
output_format 1
compress_level 9
decimal_digits 3
page_width 210mm
page_height 297mm
horigin 1in
vorigin 1in
% pdftex.map is set up by texmf/dvips/config/updmap
map pdftex.map
% This shows how to add your own map file. 
% Remove the comment and adjust the name:
map +hierofonts.map
map +diacrFonts

.map

I don't know to which comment it's referred this message which was in the pdftex.cfg

  • 1
    Welcome to TeX.SX! It's always better to copy&paste code or error messages instead of making a screenshot of it. Did you look in the log file as suggested in the error message? – dexteritas Sep 19 '18 at 13:15
  • Thanks for welcoming me ( and correcting my typos... ;) ) I had to screenshot the message because for some weird motivation it cannot be copied... Regarding the log message I can copy and past the last lines, because i did a lot of trials and I don't want to create confusion. – Luigi Masala Sep 19 '18 at 16:44
  • You can click "edit" to add the log content to your question and remove your comments. – dexteritas Sep 19 '18 at 16:47
  • problem solved I kindly ask the admins to close the thread – Luigi Masala Sep 19 '18 at 18:39
  • If you think that someone else could have this problem, it would be useful to post your solution. Otherwise the question can be closed. – dexteritas Sep 20 '18 at 8:38
1

Solution
Finally I found the solution digging in StackExchange itself (So to remind me that it's better to dig into the already existing posts than creating new ones...).
Anyway the solution can be found here in the best voted answer. I have an additional note. after the installation the package was still not working well, since most of the features ( for instance and \environment) were not recognized as defined. The point is that the manual suggest to add only the following command line to include the package in the document
\usepackage{hiero} Unfortunately there was a missing include in the hiero.sty file which was making the whole content of egypto.sty was hidden to the system. The solution to have the package fully working is the following:
Open hiero.sty and add almost at the beginning the
\include{egypto.sty}
My final result is the following
final result

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.