1

I am running LyX 2.3.1 on OS X 10.13.6 with the latest MacTex distribution. I've also updated the installed packages with TeX Live Manager recently.

Question mark boxes appear next to some menu items in LyX, as in this photo:

Question mark boxes in LyX menu

Does anyone know why this is happening, and how to fix it? Presumably, LyX is trying to render a symbol that doesn't exist on my system, but I don't see why that would be the case.

I know it's not really a major issue, and I can safely ignore it. However, seeing these symbols really bugs me, so I'd really appreciate it if someone can suggest a way to fix it. I've tried deleting the app and downloading a new copy, but that hasn't helped.

Edit: I can't find any mention of this issue online, so it appears to be just a problem on my system. If anyone here has LyX, I'd appreciate it if you could check what the menu above looks like on your system. You should find it under Edit > Text Style.

  • Welcome to TeX.SX! It seems like a problem with the typeface/font used to display these items, and it has nothing to do with LaTeX packages. Probably the font does not contain the proper glyph to show those symbols. – Ruixi Zhang Sep 20 '18 at 18:09
  • @RuixiZhang Thanks. Yes, I thought that too, so I used the system's Font Book app to restore the system fonts and validate the restoration. That didn't seem to help. Does this mean I should post this question on a different SE site instead? – Theoretical Economist Sep 20 '18 at 18:15
  • Have you tried rebooting the system after the font restoration? – Ruixi Zhang Sep 20 '18 at 18:24
  • @RuixiZhang That is a good suggestion. I hadn't at the time I posted my previous comment. I have now, and I still have the same issue. – Theoretical Economist Sep 20 '18 at 18:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.