1

I am using a laptop with a 4k screen. Texmaker works perfectly on it. Recently I got a monitor with a 1080p screen and when I link the monitor and extend the screen, the texmaker becomes blurry on the external monitor (The reason I bought it is that I want to look at other files such as a pdf file and type on the external monitor at the same time). It is still fine if I drag the interface back to my laptop but as I move it to the external monitor it becomes not clear: the fonts are small, the pdf is blurry. It also looks fine if I choose to duplicate the screen instead of extending it. Anyone knows how to fix this? Thanks in advance. (I am using Win10)

| improve this question | | | | |
  • Welcome to TeX.SE! I am not sure to which extent this is really a LaTeX problem/question. You may first want to check if this is specific to texmaker, or if other applications have the same problem. – user121799 Sep 20 '18 at 23:51
  • Hi! I just tried to use some other applications such as Stata, Pycharm, RStudio, Eclipse, Matlab. It turns out that some of them works well (Pycharm, Eclipse, Matlab) and the rest don't. Either fonts are too small, too big, or there is a problem with the GUI. Applications such as Mail, Chrome, are all fine. – Hank Chen Sep 21 '18 at 2:30
0

Depending on your Operating System your Scale and Layout settings for each monitor may need adjusting in Display Advanced scaling settings or Resolution. On some systems it is possible to adjust on a per application basis, however when using 2 or more monitors I focus my working on the best one and keep all others at the default recommended resolution and scale (usually 100%) then use zoom to adjust e.g. enlarging details. This reduces "fuzziness" which is usually down to "font smoothing" If your using a mac see mac-screen-blurry

There are several ways this dpi issue can be changed in some TeX editors, so for example TeXmaker version 5 (64bit) is scalable and has an start-up option -dpiscale 2.0 (Note not 200 like I tried :-) you will neeed to experiment for your optimum value between 1.0 and say 3.0, unfortunately I don't know how it will behave so 1.333 may work, please let us know.

| improve this answer | | | | |
  • Hi! Thanks for your response! I just tried to set scaling and I just found one solution (not perfect) to my problem. On my laptop the scaling used to be 250% and when I set the external monitor to be the main display, and change the scaling of my laptop to be 100%, and then use texmaker on the external screen, the pdf becomes clear. But the fonts and icons on the laptop becomes small. I guess I will just have to make this change everytime I want to use latex and since other applications are fine, this might not be very troublesome I hope. – Hank Chen Sep 21 '18 at 3:22
  • Rather than 250 (or even 150) you may have had better results with 200 since that = exactly 2 times thus pixelated fonts may look "blocky" but not "fuzzy" – user170109 Sep 21 '18 at 9:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.