1

Possible Duplicate:
How can I manually install a package on MiKTeX (Windows)

I have put together a user-defined package stored in a .sty file.

Using MiKTeX 2.9 on Windows 7, I've placed the file in the same directory as all other .sty files and I've run initexmf --update-fndb, yet pdflatex is still giving me the mypackage.sty not found error.

What am I doing wrong?

2
  • 2
    Have you placed the file mypackage.sty in a directory named mypackage in the LOCALTEXMF tree? If so, be sure to bring up the "MiKTeX Settings" dialogue page -- once up, it'll say "MiKTeX Options" in the header -- click on the "Roots" tab, and enter the location of the LOCALTEXMF directory (e.g., \localtexmf) by clicking on the "Add..." button. Then go back to the "General" tab and click on "Refresh FNDB".
    – Mico
    Commented Feb 20, 2012 at 20:12
  • I have mypackage.sty in a mypackage directory. This directory is in the same directory as all the other packages. MiKTeX Options shows this be under a MiKTeX-maintained root directory. Do I still need to "Add"? I try doing "Refresh FNDB" but still get the error. Commented Feb 20, 2012 at 21:17

0

Browse other questions tagged .