5

I have beamer presentations I've been using for some years in class. This year, I discovered problems with the libertine package and following advice from this forum (Libertine package options with boldface and emphasis change numeric text) switched to libertinus. I now find that the various math arrows in my presentations fail to display.

Here's an MWE:

\documentclass{beamer}

\usetheme{Warsaw}
%EDIT: inserting \usefonttheme{professional fonts} here avoids the problem
\usepackage{libertinus}% works fine with libertine

\begin{document}
\begin{frame}{Frame name}
\begin{itemize}
\item This is text.
\item Rightarrow ($\Rightarrow$)
\end{itemize}
\end{frame}
\end{document}

I have determined that

  1. replacing libertinus with libertine works fine; or
  2. replacing xelatexmk with pdflatexmk works fine; or
  3. replacing beamer with (say) article works fine.

It seems to be this particular combination.

xelatexmk was part of the MacTeX bistro and moved from the inactive engines folder. I do need XeLaTeX but perhaps this is no longer the way to do this?

I am curious as to the nature of the conflict....

EDIT: the suggestion by jfbu below does indeed solve my problem. From the beamer documentation regarding professionalfonts:

Beamer normally replaces certain character glyphs in mathematical text by more appropriate versions. .... If your professional font package takes care of this already, Beamer’s meddling should be switched off [by using \usefonttheme{professionalfonts}].

I still wonder why the problem was introduced in this specific combination, however! (but can live in ignorance if need be :) )

EDIT #2: It would appear that the beamer package issue which I reported earlier today has already been addressed (Turn off font substitution for unicode-math) and should be implemented shortly. In effect, `beamers changes will be also suppressed when a unicode-math is loaded.

2
  • you may raise a ticket on the beamer issue tracker asking that the maintainer adds libertinus to the list of packages automatically triggering the equivalent of \usefonttheme{professionalfonts}.
    – user4686
    Sep 22, 2018 at 18:24
  • 1
    I've just posted it (issue #508) as per your suggestion. Sep 22, 2018 at 18:54

1 Answer 1

4

This works for me:

\documentclass{beamer}

\usetheme{Warsaw}
\usefonttheme{professionalfonts}
\usepackage{libertinus}

\begin{document}
\begin{frame}{Frame name}
\begin{itemize}
\item This is text.
\item Rightarrow ($\Rightarrow$)
\end{itemize}
\end{frame}
\end{document}

enter image description here

This is XeTeX, Version 3.14159265-2.6-0.99999 (TeX Live 2018) (preloaded format=xelatex 2018.9.21)  22 SEP 2018 19:25
2
  • putting the thing in a box one can confirm .\TU/libertinusmath-regular.otf(1)/m/n/10.95 glyph#1974 it uses good font. (\showoutput does not work in beamer frame!)
    – user4686
    Sep 22, 2018 at 17:33
  • 1
    It got pointed out to me that \showouput works if one inserts it before \begin{document} for example...
    – user4686
    Sep 22, 2018 at 18:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .