My texstudio is crashing whenever I do this:

I have a bunch of \input{files} because I'm writing a large document. When writing, I commented out most of the inputs to speed up the compile process. However, when I uncomment all the inputs, my texstudio crashes all the time. It seems like texstudio cannot handle the large files.

Anyway to overcome this problem?

  • what type of error are you getting? what does the log files say? – naphaneal Sep 23 '18 at 19:32
  • Texstudio just closes itself. Nothing generated. Now I'm editing in text and running in cmd. – Jerry Sep 23 '18 at 20:36
  • 1
    Which version of TXS, what OS? You might try deactivating the automatically load included files option in Configure TeXstudio -> Editor (with show advanced options checked) – Troy Sep 23 '18 at 20:45
  • A few basics [1] estimate the final file size by binary chop, uncomment half and if it does not fail look at result size and double it, if fails re comment a quarter so only 25% is processed if it works quadruple the result) [2] look for high res images, comment those out. Does it run? If so consider reducing dpi, same for any other large embedment [3] confirm the disk source/temp/target has no limitations e.g. free space – user170109 Sep 24 '18 at 0:43
  • Thanks guys. After unchecking the automatically load include files, it works. – Jerry Sep 26 '18 at 2:20

TeXstudio does a lot of pre-loading, scanning and analyzing behind the scenes which may spell trouble if you are including many large files and/or if you have an old system. You can turn off this option by deactivating automatically load included files in Configure TeXstudio -> Editor (with show advanced options checked on the bottom left corner of the Config dialog). Then you should have a smoother experience with TXS / not have TXS crash so often.

In that case, you would have to keep the \include-d files open in TXS if you want to use any defined commands, labels etc. from that file and have them prompted to you by TXS.

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.