0

I am trying to do page layout with miktex 2.9 (auctex front end) and am having trouble installing the tools package (in order to use the multicol environment). The hangup right now is that there is no tools.sty file where miktex expects to find it. I downloaded the ctan tools.zip file and tools.zip isn't there either. I ran latex on tools.ins but that didn't create the style file either. Any help?

Thanks, Ed

  • ... and tools.sty isn't there either .... – caudex Sep 23 '18 at 19:47
  • 1
    you should never have to get tools.zip from ctan, it is part of the required core latex release and if you have latex at all you should have it already. It may be that your paths are wrong but hard to tell from the given information – David Carlisle Sep 23 '18 at 19:52
0

As David has pointed out tools package (and thus multicol.sty) should have been installed by default. You can check it was installed via Console, however whilst there its always a good idea to UpdateDB and then check, make a note of the install to: for future reference (ignore my H:\MiKTeX app) but check your \texmfs\install is not different. Confirm your path is not too complex (e.g. avoiding accented characters). enter image description here

Also whilst your there check Settings > General tab and ensure Package installation (for now) is set to Always install. If it's otherwise keep a note of which and you can reset it, if you wish, after you try another Packages Update (and Update DB) and re-compile sequence.

Again whilst your there (in console) check Settings > Directories tab. There should be at least three main central entries for Config, Data & Install, check they look reasonable (if you are in doubt, cut and paste the one below centre for Bin into your question) The Bin should look similar to the above Install but read ...\install\miktex\bin and the Log one should be similar to your data line but end ...\data\miktex\log.

  • Thanks, David and KJO. One thing I didn't mention is that this miktex install was done by Administrator win7.64 and when I recently did packages update I had to run: – caudex Sep 28 '18 at 15:57
  • Thanks, David and KJO. One thing I didn't mention is that this miktex install was done by Administrator win7.64 and when I recently did packages update I had to run: initexmf --admin --update-fndb initexmf --admin --mklinks --force .... in order to get latex to work at all. From my perspective , the main problem is that there is no tools.sty file in directory ...tex\latex\tools and even stranger, Package Information shows a file tools.tpm but that doesn't appear in any of the usually suspect directories. Will I have to reinstall the whole thing as a user without admin rights? – caudex Sep 28 '18 at 16:24
  • Sorry about the truncated comment. I didn't know there was a 5 minute time limit for editing comments. I didn't understand the instruction about cut and paste below centre. The directories page shows: Path Purposes Attributes C:\Users\Administrator\AppData\Roaming\MilCTeX\2.9 Config.Install C:\Users\Administrator\AppData\Local\MiKTeX\2.9 Data C:\ProgramData\MiKTeX\2.9 Config.Data Common C:\Program Files\MiKTeX 2.9 Install Common C:\Program Files\MiKTeX 2.9\miktex\bin\x64 – caudex Sep 28 '18 at 16:33
  • Ok if you typed them correctly that does look like a jumble, however I guess in haste to beat the clock, a few may not be exact. What level do you usually / wish to run as. (Personally I run as an administrative user but not as administrator) – KJO Sep 28 '18 at 17:40
  • Tnx, kjo. They were screen shot and ocr'd since miktex doesn'n seem to allow copypaste from that subwindow. It's correct except for MilCtex\2.9 .... lC has a topology similar to K but unconnected. In windows I always run as Admin but never as root in Linux. Anyway, why can't I just download the tools.sty file from somewhere or compile some other file to produce it? It's just plaintext. – caudex Sep 28 '18 at 19:13

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.