0

I´m having this error whith some makecellcaption file I do not know. I´m using overleaf. This is my code (just post the packages, I have tables, graphs but my full document is big): Thanks

\documentclass{article}
\usepackage{makecell caption}
\usepackage[labelfont=bf]{caption}
\usepackage[utf8]{inputenc}
\usepackage[sectionbib]{natbib}
\usepackage{url}
\usepackage{amsmath}
\usepackage{cellspace}
\usepackage{array }
\usepackage{hyperref}
\usepackage[printwatermark]{xwatermark}
\usepackage{readarray}
\usepackage{xcolor}
\usepackage{geometry}
 \geometry{
 a4paper,
 total={170mm,257mm},
 left=30mm,
 right=30mm,
 top=20mm,
 }
\usepackage{siunitx}
\usepackage{graphicx}
\usepackage{booktabs}
\usepackage{float}
\captionsetup[subtable]{labelformat=simple, labelsep=colon}
\renewcommand{\thesubtable}{Panel~\Alph{subtable}}



\usepackage{tabularx}% http://ctan.org/pkg/tabularx
\usepackage{booktabs}% http://ctan.org/pkg/booktabs


\begin{document}
hi


 \end{document}
4

In your second line, you have \usepackage{makecell caption}. If you want two different packages, separate them with a comma, not a space. It might even be better to use separate imports and comment why you're using the package:

\usepackage{makecell} % to have special column headings
\usepackage{caption} % to have captions of things that don't float

That will help you to avoid ending up with a humongously long preamble that you don't need.

  • BTW, hyperref should always be the last (or nearly last) package loaded. – Teepeemm Sep 25 '18 at 2:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.