0

I must have messed up my latex installation and I do not know how to clean it up. Some time ago I installed the emerald fonts using the procedure detailed at

Install emerald font package on ubuntu

After some troubles and a new installation of a lot of stuff on my system, if I now try to install latex/tex, here is what I get

Setting up tex-common (6.06) ...
Running mktexlsr. This may take some time... done.
Running updmap-sys. This may take some time... 
updmap-sys failed. Output has been stored in
/tmp/updmap.am0ezlnt
Please include this file if you report a bug.

Sometimes, not accepting conffile updates in /etc/texmf/updmap.d
causes updmap-sys to fail.  Please check for files with extension
.dpkg-dist or .ucf-dist in this directory

dpkg: error processing package tex-common (--configure):
subprocess installed post-installation script returned error exit      status 1
Errors were encountered while processing:
tex-common
E: Sub-process /usr/bin/dpkg returned an error code (1)

If I look at the log file this is what I get

$ sudo more /tmp/updmap.am0ezlnt
updmap will read the following updmap.cfg files (in precedence order):
  /root/.texlive2016/texmf-config/web2c/updmap.cfg
  /etc/texmf/web2c/updmap.cfg
  /usr/share/texmf/web2c/updmap.cfg
  /usr/share/texlive/texmf-dist/web2c/updmap.cfg
 updmap may write changes to the following updmap.cfg file:
 /root/.texlive2016/texmf-config/web2c/updmap.cfg
 dvips output dir: "/var/lib/texmf/fonts/map/dvips/updmap"
 pdftex output dir: "/var/lib/texmf/fonts/map/pdftex/updmap"
 dvipdfmx output dir: "/var/lib/texmf/fonts/map/dvipdfmx/updmap"
 updmap [ERROR]: The following map file(s) couldn't be found:
 updmap [ERROR]:    emerald.map 
 (in /root/.texlive2016/texmf-config    /web2c/updmap.cfg)
  updmap [ERROR]: Did you run mktexlsr?

You can disable non-existent map entries using the option
  --syncwithtrees.

I reran mktexlsr and used syncwithtrees without success. I am banging my head against the wall and google did not help. Any suggestion is appreciated.

1
  • from the log file it seems that you have a quite old texlive installation. i would recommend to use github.com/scottkosty/install-tl-ubuntu instructions on how to uninstall completely previous installation and to install a newer version
    – Yorgos
    Commented Sep 25, 2018 at 22:39

2 Answers 2

1

Check what /root/.texlive2016/texmf-config/web2c/updmap.cfg contains, and remove the line Map emerald.map from it. Best would be anyway to remove the while file. Then run updmap-sys again.

0

And thanks for your suggestions! Finally, what appears to be working for me is a combination of the following

How to remove everything related to TeX Live for fresh install on Ubuntu?

https://askubuntu.com/questions/616309/cannot-configure-tex-common-after-failed-font-installation

I think the real problem was some leftover of the latex installation under root. Tricky stuff! I have never thought that I should post about how to uninstall latex.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .