I have just got my first Mac and I'm trying to setup Latex on my system. Everything seems to work fine, except that MiKTeX refuses to hyphenate words, and as a result my rows overflows the width of the page when I have too long words. I get warning messages like:

Overfull \hbox (33.25203pt too wide) in paragraph

And the right margin is destroyed: enter image description here It doesn't matter which compiler I use. I have tried XeLaTex, PdfLaTeX, LaTeX, LuaLaTeX, and Latexmk.

It doesn't matter which incisions I have. In the above example the .tex file is very simple:

\documentclass[a4paper]{article}

\begin{document}
Loremipsum dolorsit amet, vixerror choroveniam at. Novix evertiturvituperatoribus. Unumintellegam estno, omnislobortis reformidansnec te. Nullam vituperatoribus usuex. Sitte meliusdebitis, eusit laboresinermis repudiare. Utamurminimum iusno, hisquando facilisisin, eigraeci laoreet eam. Seaei dictasperfecto, integreeruditi copiosaenequi. Cumei dicamfacilisi erroribus. Dictacongue integrevisut, prodebitis inermisluptatumte. Netale constituamhis, namad nulla necessitatibus. Videinermis hisid, teassum nostronominavi nam, aliquamindoctum theophrastus nevel. Te sitdicuntepicuri.
\end{document}

I have used two different editors (TexPad and TexStudio) and both have the same problem.

I suspected that there were some missing language files. But in MiKTeX Console everything seems fine to me. enter image description here

The log file doesn't seem to contain anything useful:

This is XeTeX, Version 3.14159265-2.6-0.99999 (MiKTeX 2.9.6800) (preloaded format=xelatex 2018.9.26)  26 SEP 2018 10:41
entering extended mode
**./base.tex
(base.tex
LaTeX2e <2018-04-01> patch level 5

("/Users/eric/Library/Application Support/MiKTeX/texmfs/install/tex/latex/base/
article.cls"
Document Class: article 2014/09/29 v1.4h Standard LaTeX document class

("/Users/eric/Library/Application Support/MiKTeX/texmfs/install/tex/latex/base/
size10.clo"
File: size10.clo 2014/09/29 v1.4h Standard LaTeX file (size option)
)
\c@part=\count80
\c@section=\count81
\c@subsection=\count82
\c@subsubsection=\count83
\c@paragraph=\count84
\c@subparagraph=\count85
\c@figure=\count86
\c@table=\count87
\abovecaptionskip=\skip41
\belowcaptionskip=\skip42
\bibindent=\dimen102
) (base.aux)
\openout1 = `base.aux'.

LaTeX Font Info:    Checking defaults for OML/cmm/m/it on input line 3.
LaTeX Font Info:    ... okay on input line 3.
LaTeX Font Info:    Checking defaults for T1/cmr/m/n on input line 3.
LaTeX Font Info:    ... okay on input line 3.
LaTeX Font Info:    Checking defaults for OT1/cmr/m/n on input line 3.
LaTeX Font Info:    ... okay on input line 3.
LaTeX Font Info:    Checking defaults for OMS/cmsy/m/n on input line 3.
LaTeX Font Info:    ... okay on input line 3.
LaTeX Font Info:    Checking defaults for TU/lmr/m/n on input line 3.
LaTeX Font Info:    ... okay on input line 3.
LaTeX Font Info:    Checking defaults for OMX/cmex/m/n on input line 3.
LaTeX Font Info:    ... okay on input line 3.
LaTeX Font Info:    Checking defaults for U/cmr/m/n on input line 3.
LaTeX Font Info:    ... okay on input line 3.

Overfull \hbox (33.25203pt too wide) in paragraph at lines 4--5
[]\TU/lmr/m/n/10 Loremipsum dolorsit amet, vixerror choroveniam at. Novix evert
iturvituperatoribus.
 []


Overfull \hbox (2.522pt too wide) in paragraph at lines 4--5
\TU/lmr/m/n/10 Unumintellegam estno, omnislobortis reformidansnec te. Nullam vi
tuperatoribus
 []


Overfull \hbox (14.89603pt too wide) in paragraph at lines 4--5
\TU/lmr/m/n/10 iusno, hisquando facilisisin, eigraeci laoreet eam. Seaei dictas
perfecto, integreeruditi
 []


Overfull \hbox (10.06203pt too wide) in paragraph at lines 4--5
\TU/lmr/m/n/10 copiosaenequi. Cumei dicamfacilisi erroribus. Dictacongue integr
evisut, prodebitis
 []


Overfull \hbox (12.71202pt too wide) in paragraph at lines 4--5
\TU/lmr/m/n/10 inermisluptatumte. Netale constituamhis, namad nulla necessitati
bus. Videinermis
 []

[1

] (base.aux) ) 
Here is how much of TeX's memory you used:
 203 strings out of 429720
 2087 string characters out of 3179525
 58063 words of memory out of 3000000
 4157 multiletter control sequences out of 15000+200000
 3648 words of font info for 15 fonts, out of 3000000 for 9000
 0 hyphenation exceptions out of 8191
 22i,4n,17p,592b,107s stack positions out of 5000i,500n,10000p,200000b,50000s

Output written on base.pdf (1 page).
  • 3
    something is very wrong with your setup. the US English tables do not usually hyphenate the pseudo-latin lipsum text well, but they do manage to hyphenate that example with no overfull lines. Can you show the log file you get from that example. The US hyphenation tables are not an optional part of a tex distribution so they should always be installed. – David Carlisle Sep 26 at 9:15
  • I get the output you show if I disable hyphenation with, for example \hyphenpenalty=10000 in the preamble, so you could add \showthe\hyphenpenalty and report the value that TeX says.... – David Carlisle Sep 26 at 9:22
  • @DavidCarlisle I added the log file to the post. – stack-delay Sep 26 at 10:55
  • 2
    your log file *does show something useful, it seems to show you have no languages loaded (it should say something like LaTeX2e <2017-04-15> Babel <3.15> and hyphenation patterns for 84 language(s) loaded. at the top did you get an error when miktex made the formats? – David Carlisle Sep 26 at 12:39
  • 2
    The US hyphenation patterns (hyphen.tex) are a part of the knuth-lib package. You should make sure that this package is installed and then run initexmf --mklangs followed by initexmf --dump to update the format files. – Christian Schenk Sep 26 at 15:11

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.