1

When the number of slides of my beamer is more than 10, the date is not displayed correctly in the inferior right corner of my slides.

\documentclass{beamer}
\mode<presentation>
{
  \usetheme{Madrid}       % or try default, Darmstadt, Warsaw, ...
  \usecolortheme{default} % or try albatross, beaver, crane, ...
  \usefonttheme{serif}    % or try default, structurebold, ...
  \setbeamertemplate{navigation symbols}{}
  \setbeamertemplate{caption}[numbered]
} 
\usepackage[utf8]{inputenc}
\usepackage[spanish]{babel}
\usepackage{chemfig}
\usepackage[version=3]{mhchem}
\usepackage{caption}
\usepackage{epstopdf}
\usepackage{comment}
\usepackage{graphicx}
\usepackage{subfig}
\definecolor{ao(english)}{rgb}{0.0, 0.5, 0.0}
\usepackage{pgfpages}
\pgfpagesuselayout{resize to}[%
  physical paper width=8in, physical paper height=6in]
\title[Unal%iversidad Nacional de Colombia
]{}
\author{Juan Muñoz
}

\date{\today}

\begin{document}

\begin{frame}
  \titlepage
\end{frame}

% These three lines create an automatically generated table of contents.
\begin{frame}
\end{frame}
\begin{frame}
\end{frame}
\begin{frame}
\end{frame}
\begin{frame}
\end{frame}
\begin{frame}
\end{frame}
\begin{frame}
\end{frame}
\begin{frame}
\end{frame}
\begin{frame}
\end{frame}
\begin{frame}
\end{frame}
\begin{frame}
\end{frame}
\begin{frame}
\end{frame}
\begin{frame}
\end{frame}

\end{document}

¿How could I fix it?

3

Try with the following redefinition of the footline:

\documentclass{beamer}
\mode<presentation>
{
  \usetheme{Madrid}       
%  \usecolortheme{default} as the name says, this is default
  \usefonttheme{serif}    
  \setbeamertemplate{navigation symbols}{}
  \setbeamertemplate{caption}[numbered]
} 
\usepackage[utf8]{inputenc}
\usepackage[spanish]{babel}
\usepackage{chemfig}
\usepackage[version=3]{mhchem}
\usepackage{caption}
%\usepackage{epstopdf} not needed with current tex distributions
\usepackage{comment}
%\usepackage{graphicx} not needed with beamer
\usepackage{subfig}

%\definecolor{ao(english)}{rgb}{0.0, 0.5, 0.0} Better not use () in colour names 

\usepackage{pgfpages}
\pgfpagesuselayout{resize to}[physical paper width=8in, physical paper height=6in]

\makeatletter
\setbeamertemplate{footline}{%
  \leavevmode%
  \hbox{%
  \begin{beamercolorbox}[wd=.333333\paperwidth,ht=2.25ex,dp=1ex,center]{author in head/foot}%
    \usebeamerfont{author in head/foot}\insertshortauthor\expandafter\ifblank\expandafter{\beamer@shortinstitute}{}{~~(\insertshortinstitute)}
  \end{beamercolorbox}%
  \begin{beamercolorbox}[wd=.333333\paperwidth,ht=2.25ex,dp=1ex,center]{title in head/foot}%
    \usebeamerfont{title in head/foot}\insertshorttitle
  \end{beamercolorbox}%
  \begin{beamercolorbox}[wd=.333333\paperwidth,ht=2.25ex,dp=1ex,right]{date in head/foot}%
    \usebeamerfont{date in head/foot}\insertshortdate{}\hfill%
    \usebeamercolor[fg]{page number in head/foot}\usebeamerfont{page number in head/foot}\makebox[0.9cm][r]{\usebeamertemplate{page number in head/foot}}\hspace*{2ex} 
  \end{beamercolorbox}}%
  \vskip0pt%
}
\makeatother

\title[Unal]{}
\author{Juan Muñoz}
\date{\today}

\begin{document}

\begin{frame}
  \titlepage
\end{frame}

\begin{frame}
\end{frame}
\begin{frame}
\end{frame}
\begin{frame}
\end{frame}
\begin{frame}
\end{frame}
\begin{frame}
\end{frame}
\begin{frame}
\end{frame}
\begin{frame}
\end{frame}
\begin{frame}
\end{frame}
\begin{frame}
\end{frame}
\begin{frame}
\end{frame}
\begin{frame}
\end{frame}
\begin{frame}
\end{frame}

\end{document}

enter image description here

enter image description here


If you are using beamer v3.54 you could also use this version of beamerbaseauxtemplates.sty in which I fixed the problem.

  • When I copy your code to mine I dont know were I have to paste it because you erase a lot of things of my original code. However I past it before the command \begin{document}, and also try pasting it after the command \usepackage[spanish]{babel}, but none worked. Both showed me compiling errors. Where do I have to paste it?, also could you please add all the commands that my minimal working example had? !Thanks in advance! – JuanMuñoz Sep 29 '18 at 0:38
  • @JuanMuñoz It does not matter where you put this in your preamble. Can you show which error message you get? – samcarter is at topanswers.xyz Sep 29 '18 at 12:38
  • @JuanMuñoz I added all the packages which make sense with beamer – samcarter is at topanswers.xyz Sep 29 '18 at 12:42
  • The error message is this "Undefined control sequence. <recently read> \ifblank l.47 \begin{document}" – JuanMuñoz Sep 29 '18 at 13:55
  • @JuanMuñoz Which version of beamer do you have? – samcarter is at topanswers.xyz Sep 29 '18 at 13:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.