0

I installed scheme-full of TexLive, and everything was okay until I rebooted my PC. Then all cyrillic fonts went missing, and mktexmf started printing such messages during the build (question marks denote cyrillic characters):

name = larm1000, rootname = larm, pointsize = 1000
mkdir C:/Users/????????? error.
Failed to access C:/Users/?????????/.texlive2018/texmf-var.
Cannot get destination directory name.

During the installation I changed TEXLIVE_INSTALL_PREFIX and set the codepage to 65001.

TEXDIR is C:\Programs\texlive\2018.

How can I point mktexmf to a correct directory?

  • Welcome to TeX.SX! Which editor do you use? – Bobyandbob Sep 30 '18 at 6:00
  • Hello, I use TeXstudio, but it's not the source of the problem. I could reproduce the issue manually running mktexmf larm1000.mf in cmd – Alex Sep 30 '18 at 6:04
1

I checked TexLive's variables listed at http://tug.org/texlive/doc/texlive-en/texlive-en.html#x1-100002.3, and TEXMFVAR was pointing to the wrong location. Setting it to %TEXDIR%\texmf-var using tlmgr conf texmf fixed the issue

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.