1

After updating to the latest version of TeXShop, every paragraph in my source displays with the second and subsequent lines indented. This is true for new and old documents. How do I disable this behavior?

TexShop potential bug on OSX

  • I don't work with TeXShop; so, no immediate answer. But what I notice is those are not multi-line paragraphs, but rather wrapped lines. So, look at how your system is set up to handle wrapping text. – A.Ellett Oct 2 '18 at 20:18
  • 1
    This is a feature. You can control it from the Editor tab of TeXShop—>Preferences. – Herb Schulz Oct 2 '18 at 20:29
1

From the “Changes” file, available from the Help menu:

There are additional features of TeXShop 4.08 that are not related to Mojave:

[...]

  • Gary Gray requested that TeXShop start paragraphs flush with the left margin, but indent remaining paragraph lines. TeXShop 4.08 has this feature. Some users are in the habit of inserting line feeds when their source lines approach the right margin; they will not notice any difference. Other users type several lines of source text between line feeds. The resulting "paragraphs" will now be visible for easier scanning. This feature is controlled by two new preference settings, available under the Edit Tab. The first sets the indent of the initial paragraph line. By default this is set to 0.0. The second sets the indent of the remaining paragraph lines. By default this is set to 30.0.

enter image description here

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.